TrueVanDal

Overmax Vertis 5020 Aim - Nie działa ekran po wgraniu stockowego ROMu

1 post w tym temacie

Witam serdecznie.

Na wstępie przepraszam, jeśli ten temat powinien być jednak w kategorii "Aim" ale Overmax ma kilka tych telefonów więc ciężko ocenić.

Na początek, historia. Mój kolega dał mi rzeczony telefon (Overmax Vertis 5020 Aim), żebym trochę w nim pogrzebał, może znalazł jakiś alternatywny ROM itp. Jeśli telefon się "uwali" w trakcie to też spoko, nikt nie będzie po nim płakał. Udało mi się "skleić" TWRP (inaczej tego się nie da nazwać :p), uzyskać ROOT i wszystko szło dobrze. Postanowiłem więc wgrać jakiś Custom ROM z "podobnego" telefonu. Telefon złapał po tym bootloop, nie byłem nawet w stanie wymusić wejścia do Recovery, żeby przywrócić backup więc uznałem, że najlepiej będzie jak po prostu wgram czysty soft ze strony producenta. Ściągnąłem go z tej strony: "http://www.overmax.eu/product/vertis-5020-aim/#item-product-support . Odpaliłem SP Flash Tool, wybrałem scatter file, i spróbowałem wgrać tylko boot.img i tylko system.img... ale dostałem informację, że "DA" się różni (zakładam, że chodzi o rozłożenie partycji względem tego co było już na telefonie?) i z tego co znalazłem w internecie podobno trzeba "sformatować" pamięć i wgrać wszystko od nowa. Tak też zrobiłem i niestety, telefon się odpalił ale z jakoś "dziwnie" działającym wyświetlaczem. Matryca jest podświetlona ale nic nie widać, albo widać jakieś ciemne kwadraty, ciężko to opisać ale ważne jest, że nie widać na ekranie nic poprawnie. Chcę podkreślić jedno, ekran źle działa od momentu włączenia, nie widzę nawet loga poprawnie.

Ale, co ciekawe, poza tym telefon zdaje się działać, tzn. jeśli poczekam dłużej, android się boot-uje, niestety, bez możliwości zobaczenia co jest na ekranie ciężko jest zrobić cokolwiek. "Pod spodem" widać wtedy jakieś kwadraciki i jestem tylko w stanie potwierdzić, że "coś działa" i że dotyk też działa, ale nawigować się nie da. Mało tego, jeśli przycisnę VOL+ i POWER to teoretycznie trafiam na ekran wyboru Normal, Recovery, Fastboot (dalej nic nie widać ale przy odrobinie szczęścia jestem w stanie wybrać np. fastboot). PC rozpoznaje urządzenie i po kablu jestem w stanie dostać się do fastboota, niestety, po pełnym wgraniu ROMa bootloader jest znowu zablokowany a żeby go odblokować muszę najpierw zezwolić na to w ustawieniach developerskich które są... no wiecie, w Androidzie.. a przecież ekran mi nie działa :D.

ADB widzi urządzenie ale nie mogę się połączyć, bo jest "unathorized" a bez ekranu raczej nic nie potwierdzę. Ale na upartego mogę wgrać swoje TWRP gdzie adb jest odblokowane i przy odrobinie szczęścia mogę przejść przez ekran wyboru do recovery i stamtąd odpalić ADB... jeśli to okaże się przydatne, bo dla mnie nie było niestety :/. Niemniej taka opcja istnieje i sprawdziłem to.

OK, taki efekt był na pierwszym sofcie, sprawdziłem też drugi ze strony Overmaxa, czyli "Fix camera soft", efekt jest identyczny, urządzenie się bootuje, ale to tyle, ekran nie działa poprawnie. Zauważyłem, że w tym drugim sofcie scatter file jest inny, czyli "partycje" są nieco inaczej ułożone na EMMC.

 

Z tego co czytałem, problemy z wyświetlaczem mogą wynikać z nieprawidłowego pliku lk.bin (to chyba jest generalnie bootloader urządzenia, "little kernel") i chyba po części to potwierdziłem... Zacząłem szukać innych stokowych ROMów, i trafiłem na ten telefon Zopo Color E, ściągnąłem do niego ROM (można go znaleźć na tej stronie http://www.zopomobile.com/download/color/), wgrałem najpierw wersję Lolipop, potem Marshemllow i ... telefon się odpala na obu wersjach, ekran działa ale po załadowaniu androida nie działa dotyk. Niemniej ciekawe jest, że udało mi się trafić na inny model telefonu, który "prawie" działa.

 

Zacząłem kombinować z kombinacjami w SP Flash Toolu, czyli np. scatter z Zopo ale obrazy z Overmaxa ale w najlepszym razie miałem bootloop chwilkę po zobaczeniu loga Overmax. Wszystko wskazuje na to, że w stokowym ROMie walnięty jest plik lk.bin. Nie mogę niestety użyć tego pliku z Zopo, gdyż mam bootloop. Za mało wiem o tym jak te pliki ze sobą współgrają żeby dojść do jakichś innych ciekawych wniosków. Sprawdzałem też jeszcze kilka innych ROMów, z "podobnych" telefonów ale tam też ekran po wgraniu nie działał poprawnie, a jeden z ROMów prawie uwalił telefon (PC potem go w ogóle nie wykrywał, chyba cudem udało mi się jakoś wgrać znowu stock Overmaxa) więc trochę się boję :p. Acha, wyciągnąłem z backupu TWRP lk.bin, boot.img i kilka innych, ale ich wgrywanie przez SP Flash tool też nic nie zmienia, dalej ekran nie chce współpracować (to jest akurat dziwne, skoro "nowy" lk.bin nie działa, to ten z kopii powinien, ale tak nie jest, albo ja coś robię źle).

 

Udało mi się też znaleźć "kolna" rzeczonego Overmaxa (albo Overmax to klon, kto wie), bliżej chyba nie będę, spójrzcie tylko: http://i-life.us/product/s501/ problem w tym, że nie mogę dorwać do niego ROMa, a jedyny jaki znalazłem, jest chroniony hasłem którego nikt nie zna :/ (http://tanjiltalecombd.blogspot.com/2016/11/ilife-itell-s501-firmware-flash-file.html).

 

Zatem, jeśli ktoś ma jeszcze jakieś pomysły to ja z chęcią posłucham. Telefon już nie jest na gwarancji, więc do Overmaxa go nie wyślę, ale sam fakt, że na stronie producenta jest niedziałający poprawnie ROM jest co najmniej dziwne.

 

Pozdrawiam

 

PS: Szacun dla tych, którzy przeczytali całość, ale chciałem podzielić się z wami moimi doświadczeniami i to co udało mi się ustalić. Jak widzicie starałem się rozwiązać problem na własną rękę ale chyba to jest moment, żeby poprosić o pomoc kogoś bardziej ogarniętego w temacie niż ja ;).

Udostępnij link do tego posta


Odnośnik do posta
Udostępnij na stronach

Żeby dodać komentarz, musisz założyć konto lub zalogować się

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.