Skocz do zawartości

Znajdź zawartość

Wyświetlanie wyników dla tagów 'czujnik światła' .



Więcej opcji wyszukiwania

  • Wyszukaj za pomocą tagów

    Wpisz tagi, oddzielając je przecinkami.
  • Wyszukaj przy użyciu nazwy użytkownika

Typ zawartości


Forum

  • Społeczność android.com.pl
    • Regulaminy Forum
    • Przywitaj się!
    • Android.com.pl
    • Konkursy
    • OFF-Topic
  • Android
    • Nowości i plotki
    • FAQ Android
    • Android 10
    • Android 9.0 Pie
    • Android 8.0 Oreo
    • Android 7.0 Nougat
    • Android 6.0 Marshmallow
    • Android 5.0 Lollipop
    • Android 4.4 KitKat
    • Archiwum Android
    • Software PC
  • Gry i Aplikacje
    • Aplikacje Android
    • Gry Android
    • Poszukiwania gier i aplikacji
    • Porównania gier i aplikacji
    • Android Wear - Smartwatch
    • Modyfikacje Wizualne
    • Download
    • Multimedia
  • Co i gdzie kupić?
  • Programowanie
  • Modyfikacje Android OS
  • Elektronika
  • Honor
  • Google
  • HTC
  • LG
  • Samsung
  • Sony
  • Motorola
  • Huawei
  • Xiaomi / MIUI
  • OnePlus
  • Lenovo
  • Asus
  • myPhone
  • Pozostałe marki

Szukaj wyników w...

Znajdź wyniki, które zawierają...


Data utworzenia

  • Od tej daty

    Do tej daty


Ostatnia aktualizacja

  • Od tej daty

    Do tej daty


Filtruj po ilości...

Znaleziono 13 wyników

  1. Od jakichś 3-4 dni mam problem z czujnikiem jasności w Mate 10 PRO. O ile przez niemal rok odkąd mam ten telefon byłem bardzo zadowolony z jakości wyświetlacza to od tych kilku dni jest ewidentnie coś nie tak. Wspomniany czujnik jasności nie reaguje praktycznie zawsze na otoczenie tzn. reaguje owszem ale nie jest to tak jak było przedtem. Wieczorem na ulicy wyświetlacz jest nieco rozjaśniony, poprzednio ładnie stonowany i ostry. Bardzo często w pełnym słońcu mimo że suwak jest przesunięty na maxa ekran wygląda tak jakbym obniżył znacznie kontrast - jakby ekran posypany byłby kurzem. Nic szczególnego nie wydarzyło się z telefonem po prostu w pewnej chwili zaczął tak działać. Podsumowując czujnik światła reaguje ale nie daje efektu jaki powinien być i jaki pamiętam jeszcze sprzed tygodnia, ekran jakby z obniżonym kontrastem do prawie minimum jakiś taki szary bez życia. Hard reset nie pomógł. Jest jakaś pomoc w tej sprawie przed udaniem się do serwisu? Może coś po prostu się przestawiło w ustawieniach. Dzięki za pomoc.
  2. Witam, Od kilku dni mam problem z moją moto x play. Nie działa automatyczna jasność wyświetlacza (w zależności od widzimisie urządzenia ustawia max lub min jasność, suwak korekty nie działa). Wbudowana diagnostyka urządzenia pokazuje awarię czujnika zbliżeniowego. Zostało mi jeszcze kilka miesięcy gwarancji ale nie mam ochoty rozstawać się z motką na miesiąc. Zwłaszcza jeżeli to jakaś błahostka. Do tej pory byłem zadowolony. Dodam jeszcze, że telefon zakupiłem dwa miesiące temu jako używany. Pozdrawiam
  3. Witam, zauważyłem że czujnik światła działa bardzo mozolnie w wcześniejszych telefonach to działało idealnie i szybko a tu może i rozjaśniania działa umiarkowanie ale ściemnianie to porażka patrząc na telefon np. w samochodzie po zmroku to ekran cały czas mnie razi zdążę spokojnie nawiązać połączanie niż od pomyśli żeby się przyciemnić... mam znajomego co tez ma s8 i mówi że u niego jest dokładnie taki sam problem, ekran bardzo powoli po jakimś czasie zaczyna się ściemniać natomiast rozjaśnienia trwa 3x szybciej... najgorsze jest to że zanim on namyśli się ściemnić to już dawno mnie oślepi... też macie z tym problem? jak sobie z tym radzicie? może można gdzieś ustawić czułość czujki bądź jej szybkość ?
  4. Witam serdecznie, mój problem tkwi w małej szczelinie miedzy ekranem a krawędzią telefonu obok przycisku "home".Telefon jest nowy więc mam do czynienia z niedoróbką produkcyjną. Szczeliny w dziennym świetle nie widać ponieważ czujnik światła nie włącza podświetlenia dotykowych przycisków, jednak w nocy kiedy "home" się świeci, przerwa jest bardzo irytująca. Nie chce używać jakichś klejów czy uszczelek bo boje się, że mogę pogorszyć sprawę. Wpadłem więc na pomysł wyłączenia podświetlanych przycisków. Niestety jestem zielony w sprawach systemowych dlatego bardzo proszę o pomoc. Ps. To nieodosobniony przypadek dlatego, że znalazłem posty w wątku "niedoróbki produkcyjne" tego samego problemu. Załączam zdjęcia jak wygląda to w ciemności. (Zdjęcia nie są moje, ściągnąłem je od jednego z użytkowników z wątku o, którym pisałem, jednakże mam identyczną wadę produkcyjną)
  5. Witam, dopatruję się problemu z czujnikiem światła w Motce. Od razu zaznaczam, że nie mam zakrytego czujnika przez folię, telefon w tym miejscu jest czysty i nic go nie przysłania. Nie chodzi mi też o jasność ekranu dla "ciemności", gdzie rozumiem najniższą intensywność światła rozpoznawaną przez telefon - wiem, że można to regulować poprzez suwak przy automatycznym podświetleniu. Problem leży w tym, kiedy ten najniższy poziom jest wychwytywany. Zauważyłem, że gdy mój poprzedni telefon nie schodzi jeszcze do najniższej wartości podświetlenia, to motka przyciemnia już ekran do ustawionego minimum, co chwilami jest niewygodne w użytkowaniu, bo ekran wydaje się za ciemny. Z kolei przestawienie minimalnej wartości podświetlenia na wyższą okazuje się być za mocna dla kompletnej ciemności - po zgaszeniu źródeł światła. Najniższa ustawiana automatyczna jasność zależna jest od wartości, jaką daje czujnik. Przeprowadziłem więc prosty test miedzy dwoma telefonami (Lumia 930 i X Play) instalując na nich programy odczytujący wartości z czujnika. Następnie zmierzyłem natężenie światła umieszczając telefony w tych samych miejscach w niezbyt jasnym pomieszczeniu. Wyniki pomiaru przedstawiąją się następująco (w lux): X Play Lumia 930 1 ......... 4 4 ......... 6 20 ......... 28 20 ......... 40 20 ......... 70 2700 ......... 1120 W przypadku zakrycia czujnika palcem oba urządzenia wskazują wartość 0. Pomijam fakt, ze czujnik w Motce przycina się do pewnej wartości do około 20 lux. Dla bardzo niskich wartości, mniejszych niż 10, Lumia wykazuje większą dokładność i czułość na zmianę światła. Kiedy X Play oscylowała między wartością 0-1, Lumia miała wartości od 4 do 5, czyli jeszcze nie najniższe wartości. Dopiero po przysłonięciu palcem czujnika Lumia przyciemniała ekran do wartości minimalnej. Tymczasem ekran w Motce był już wygaszony. Może trochę się nad tym rozczulam, ale w momencie, kiedy jeden telefon działa zgodnie z oczekiwaniami, a drugi odstaje od tych oczekiwań staję się marudny Pytanie do Was: da się to skalibrować we własnym zakresie? Ten typ tak ma? Zauważyliście podobne zachowanie w swoich telefonach? Proszę o podzielenie się uwagami.
  6. Witam, od jakiegoś czasu korzystam z Doogee x5 , i mam pewien kłopot ponieważ w momencie rozmowy z kimkolwiek dotykam policzkiem ekranu i zawieszam rozmówcę , jest to związane z czujnikiem światła - zbliżeniowym ? Generalnie trzeba trzymać telefon w dziwnej pozycji , wręcz dociskać go do twarzy aby nie uaktywnić (podświetlić) ekranu .Ma ktoś jakiś pomysł jak to ominąć , dezaktywować ?
  7. black_jack

    Problem z czujnikiem światła

    Z czujnikiem jest ten problem, że właśnie nie jest za ciemno, a za jasno. Ostatnio stałem na peronie i wyświetlacz robił niezła dyskotekę "jasno - ciemno", mimo, że warunki się nie zmieniały. W ciągu dnia jest ok, ale przy sztucznym świetle bywa, że wariuje i rozjaśnia/przyciemnia bez powodu. Być może to wada, wiec przyjrzyj się proszę, czy doswiadczasz nagłych zmian podświetlenia, gdy używasz telefonu w tych samych warunkach. Dzięki Wysłane z mojego Nexus 6P przy użyciu Tapatalka
  8. Witam Poszukuje smartfona do 500zł, w miare możliwy jak najwiekszy wyswietlacz, dobry aparat i GPS Przynajmniej 8GB pamieci wew Minumum 1GB RAM Pewna gwarancja najlepiej 24m Android Kit Kat Opcjonalne: Wyswietlacz w HD LTE Mój typ to: MyPhone S-LINE 16GB najtaniej znalazlem za 429zł http://selgros24.pl/Telefony-i-akcesoria/Telefony-kom%C3%B3rkowe/myPhone/SMARTFON-MYPHONE-S-LINE-CZARNY/2_50344.do Wadą jest trochę słaby procesor i w tym modelu bardzo słabo działa czujnik zbliżeniowy(czasami prawie nie działa podczas rozmowy tel świeci nawet przy dociskaniu do twarzy) Rozważam też zakup z zagranicy, np XPERIA Z http://allegro.pl/oryginalny-sony-xperia-z-3-kolory-gw-24-mce-i5362895323.html Cena bardzo niska, trochę boje sie kupować z zagranicy, ktoś coś wie o tym sprzedawcy? Czekam na opinie i inne propozycje
  9. Witam, przeszukałem już internet w sprawie cz. światła w ace 2. I nigdzie nie ma jasno powiedziane, że ace 2 ma lub nie ma czujnika światła który odpowiada za automatyczne rozjaśnianie/ściemnianie ekranu.. Może Wy będziecie to wiedzieć. Może jest jakiś sposób, żeby go odblokować/wykorzystać o ile on jest. Fajny z tego gadżet i bardzo przydatny.
  10. Witam mam pytanie o czujnik światła w S-ce we wszelkich specyfikacjach jest on wyodrębniony jako by miał się znajdować w telefonie lecz czemu nie da się go wykorzystać w telefonie do ustawiania jasności ekranu? Czy może jest jakaś apk która może nim sterować?
  11. jerzyjerzy

    Regulacja czujnika światła

    Po przeczytaniu wątku http://forum.android.com.pl/f561/czujnik-a-wiata-a-w-xperi-s-jest-czy-go-nie-ma-359299/ zacząłem się zastanawiać, czy czujnik światła w ogóle działa. Więc tak - po pierwsze, dokładne sprawdzenie reakcji ekranu (czy raczej jej brak) przekonało mnie jednoznacznie, że automatyczna jasność NIE DZIAŁA przy domyślnych ustawieniach mojego ROMu (eXistenZ Ultra). Poszukałem trochę na XDA i znalazłem rozwiązanie. Ustawienia (między innymi) tej funkcji są zapisane w pliku /system/etc/hw_config.sh i wyglądają u mnie następująco: # LMU AS3676 Configuration dev=/sys/class/leds echo 1,51,255,39,20,6,84 > $dev/lcd-backlight/als/curve # ALS curve for group1 echo 1,0,0,0 > $dev/lcd-backlight/als/params #[gain],[filter_up],[filter_down],[offset] echo 1 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h echo 2000 > $dev/button-backlight/max_current Problemem jest wiersz /curve i, żeby czujnik jasności działał prawidłowo, trzeba go zmienić na: echo 0,0,0,0,0,0,0 > $dev/lcd-backlight/als/curve a potem zapisać plik i zrestartować telefon. Wyzerowanie parametrów krzywej powoduje wymuszenie korzystania z wartości domyślnych (jak rozumiem - z wartości opisujących grupę krzywych znajdujących się w folderze /system/etc/als_curve). Tak dokładnie, to nie wiadomo dlaczego oryginalne wartości nie działają, bo teoretycznie powinny. Być może dają nieprawidłową krzywą? Z moich prób wynika, że szereg innych wartości opisujących krzywą też włącza ten czujnik. Gdyby ktoś chciał się tym pobawić - dopuszczalne wartości wszystkich siedmiu parametrów to 0-255, przy czym, jeśli nadaje się wartości, to pierwszy parametr (oznaczający grupę krzywych) musi mieć wartość 1. Wartości parametrów to: grupa, y0, y3, k1, k2, x1, x2, gdzie: grupa - grupa krzywych, zawsze równa 1 x - graniczne odczyty czujnika dla dolnej i górnej części krzywej y - graniczne wartości jasności podświetlenia dla dolnej i górnej części krzywej k - nachylenia dla dolnej i górnej części krzywej Krzywa może być opisana jako: for(x=0;x<256;x++) { if (x<x1) y=y0; else //pierwsza, płaska część krzywej (na całej długości równa y0) if (x<x2) y=y+k1/32; else //druga, pochylona część krzywej y=y+k2/32; //trzecia, pochylona pod innym kątem część krzywej if (y>y3) y=y3; //czwarta i ostatnia, płaska część krzywej (na całej długości równa y3) curve[x]=y; } gdzie x to odczyt czujnika, a y to wartość jasności podświetlenia. Kolejny wiersz ($dev/lcd-backlight/als/params) określa parametry regulacji skoku zmiany jasności. Wszystkie cztery parametry powinny zawierać się w zakresie 0-7. Na przykład: echo 2,0,0,0 > $dev/lcd-backlight/als/params #[wartość_zmiany_jasności],[filtr_w_górę],[filtr_w_dół],[skok] Pierwsza wartość to całkowita zmiana jasności, dwie kolejne to czułości reakcji na zmianę oświetlenia w górę i w dół. Ostatnia wartość w tym wierszu to skok czasowy między kolejnymi przyciemnieniami/rozjaśnieniami (nie wiem w jakich jednostkach, tym bardziej, że wydaje się, że zależność jest odwrotna, tzn. im większa wartość, tym szybciej następuje zmiana). Podwyższenie tej wartości eliminuje mruganie/skoki jasności podczas automatycznego dostosowywania jasności przez telefon. Na przykład: echo 7,0,0,7 > $dev/lcd-backlight/als/params #[gain],[filter_up],[filter_down],[offset] daje całkowicie płynną (bez mrugania) i dość znaczną zmianę jasności w czasie około dwóch sekund. Czyli, powiedzmy, od wyjęcia z kieszeni do zobaczenia wyświetlacza. Kolejny wiersz ($dev/lcd-backlight/als/enable) włącza (1) lub wyłącza (0) czujnik: WŁĄCZONY: echo 1 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h WYŁACZONY: echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h Po paru próbach zostawiłem wartości domyślne, czyli wyzerowałem krzywą, która psuła czujnik (pomimo, że niby był włączony parametrem als/enable) i podwyższyłem parametry rozjaśniania: # LMU AS3676 Configuration dev=/sys/class/leds echo 0,0,0,0,0,0,0 > $dev/lcd-backlight/als/curve # ALS curve for group1 echo 7,1,1,7 > $dev/lcd-backlight/als/params #[gain],[filter_up],[filter_down],[offset] echo 1 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h echo 2000 > $dev/button-backlight/max_current Teraz po zasłonięciu górnej części ekranu następuje wyraźne płynne przyciemnienie, a po odsłonięciu - rozjaśnienie ekranu. A z innych ciekawostek - ostatni wiersz ($dev/button-backlight/max_current) steruje prądem podawanym na pasek LED. I, uwaga, najniższa wartość to 1 (pasek prawie niewidoczny). Wartość 0 powoduje podawanie maksymalnego prądu i bardzo wysoką jasność. Źródła na XDA - tutaj i tam
  12. mam ICS .100, kernel Transcendence i zauważyłem że na automatycznym podświetleniu ekran się sam nie rozjaśnia .... robiłem test i wiem że czujnik światła działa . Mam zaznaczone automatyczne podświetlenie ekrany . W czym problem jest ?? też tak macie ??
  13. Ładowanie i problem z marketem: Za każdym razem co podłączam oryginalną ładowarkę to mi się tak dzieje i to od kilku tygodni. W dodatku samo ładowanie trwa bardzo długo a bateria trzyma kilka godzin tylko. Rozładowuje się nawet jak telefon jest wyłączony. Trzeba wyciągnąć i włożyć baterię z powrotem, żeby się tak nie działo. Jak podłączam kablem do komputera to tak samo się ładuje, ale wyskakuje dymek "nie rozpoznano urządzenia usb". Próbowałem przeczyścić gniazdo, nawet ustawienia domyślne. Po tym zabiegu przestał mi nawet działać android market. Tzn nie można nic pobrać ani zaktualizować bo pisze cały czas pobieranie i nic więcej się nie dzieje. Czujniki to chyba w ogóle nie działają. Próbowałem programami testowymi i wartości się nie zmieniają. Światła - mimo ze w ustawieniach włączona jest auto jasność to nawet gdy zbliżę tel do żarówki jasność nie zmienia się. Zbliżeniowy - jak dzwonie do kogoś albo ktoś do mnie to po odebraniu ekran się wyłączy i nie można nic zrobić do puki rozmówca się nie rozłączy jako pierwszy, bo ekran pozostaje ciemny. Jest to szczególnie irytujące podczas gdy dzwonie do kogoś i włączy się poczta głosowa bo wtedy muszę wyciągać baterie i na nowo załączać telefon. Musiałem specjalnie kupić słuchawkę bt, bo tylko dzięki niej mogę się rozłączyć jako pierwszy. Próbowałem przeczyścić obudowę od zewnątrz jak i wewnątrz. Nawet wypiąć i wpiąć je z powrotem do płyty głównej przedmuchiwać wejścia. Zauważyłem, że po wpisaniu kodu #*0*# wchodzi się do trybu testowego. Dałem na sprawdzenie czujników i wygląda to w ten sposób, że wartości się cały czas zmieniają. Jedynie czujnik zbliżeniowy pozostaje na 0. O czym nie napisałem w temacie to o zasięgu, bo z nim też mam kłopoty. Wygląda to w ten sposób, że często się wyłącza. Nie przełącza się w tryb samolotu. Tylko transmisja danych i zasięg znikają i zamiast tej ikony pojawia się ukośnik w kółku. Próbowałem zmienić na ręczny wybór operatora, ale jest tak samo. Mam sieć play i niekiedy wyskakuje, że wystąpił problem podczas rejestrowania do sieci. Proszę o pomoc. ---------- Post dołączono 22-09-13 o 23:07 ---------- Poprzedni post napisano 21-09-13 o 23:51 ---------- nikt nie ma pomysłów?
x