Skocz do zawartości

Znajdź zawartość

Wyświetlanie wyników dla tagów 'services' .



Więcej opcji wyszukiwania

  • Wyszukaj za pomocą tagów

    Wpisz tagi, oddzielając je przecinkami.
  • Wyszukaj przy użyciu nazwy użytkownika

Typ zawartości


Forum

  • Społeczność android.com.pl
    • Regulaminy Forum
    • Przywitaj się!
    • Android.com.pl
    • Konkursy
    • OFF-Topic
  • Android
    • Nowości i plotki
    • FAQ Android
    • Android 10
    • Android 9.0 Pie
    • Android 8.0 Oreo
    • Android 7.0 Nougat
    • Android 6.0 Marshmallow
    • Android 5.0 Lollipop
    • Android 4.4 KitKat
    • Archiwum Android
    • Software PC
  • Gry i Aplikacje
    • Aplikacje Android
    • Gry Android
    • Poszukiwania gier i aplikacji
    • Porównania gier i aplikacji
    • Android Wear - Smartwatch
    • Modyfikacje Wizualne
    • Download
    • Multimedia
  • Co i gdzie kupić?
  • Programowanie
  • Modyfikacje Android OS
  • Elektronika
  • Honor
  • Google
  • HTC
  • LG
  • Samsung
  • Sony
  • Motorola
  • Huawei
  • Xiaomi / MIUI
  • OnePlus
  • Lenovo
  • Asus
  • myPhone
  • Pozostałe marki

Szukaj wyników w...

Znajdź wyniki, które zawierają...


Data utworzenia

  • Od tej daty

    Do tej daty


Ostatnia aktualizacja

  • Od tej daty

    Do tej daty


Filtruj po ilości...

Znaleziono 2 wyniki

  1. Wiam, mam pewien problem z moim telefonem LG f70 chodzi o to, że co chwile jak uzywam telefon wyskakuje czarny ekran z napisem na górze LocationServices, ustawienia fabryczne jakoś mi nie pomogły, ten błąd jest na tyle uciążliwy, że jak przeglądam internet to pojawia się na sekundę i za 4 sekundy znowu i tak parę razy potrafi, w pisaniu smsów czy też zwykłego oglądania Youtube dodam screena z błędem. Jakieś prady?
  2. Witam. Mam taką sytuację: W mojej aplikacji startuję usługę, która ma swój wątek uruchamiany w onStartCommand. Wątek usługi w pętli wykonuje sekwencję zadań - sprawdza warunki dotyczące WiFi (gdy wszystkie są spełnione to wyłącza moduł WiFi), przechodzi w stan uśpienia (od kilkunastu sekund do kilku minut) - i tak w kółko. Ma to na celu wyłączenie WiFi, gdy nie ma dostępu do Internetu, a więc najpewniej gdy zasięg został utracony, ale też gdy nie zostało ustanowione połączenie pozwalające na dostęp do Internetu. Wyłączanie modułu WiFi robię przez: WifiManager wifiManager; wifiManager.setWifiEnabled(false); Przy tym oglądam logi w Eclipsie. Przykładowa sytuacja: Nie znajduję się w obrębie znajomej sieci. Włączam program, aktywuję z niego wspomnianą usługę. Włączam moduł WiFi i... po jakimś czasie (różnym, czasem parę sekund, czasem nawet minuta) uruchamia się systemowe automatyczne skanowanie i próby łączenia do sieci w pobliżu, towarzyszy temu wizualny alert i ma to miejsce również gdy ekran jest wyłączony. Ja oczekuję, aby mimo to, moja aplikacja (w przypadku spełnienia odpowiednich warunków - braku połączenia ze znaną siecią) skutecznie wyłączyła moduł WiFi, albo przynajmniej, aby skanowanie to szybko się skończyło i wtedy moduł ma być wyłączony. Wszystko jest OK, dopóki smartfon jest podłączony do komputera. Oglądam logi; widzę na nich, że moduł WiFi został przez aplikację wyłączony; włączam ekran, widzę mignięcie zamykającego się alertu auto-skanowania sieci i rzeczywiście moduł jest wyłączony. Jednak w przypadku gdy smartfon nie jest podłączony do komputera, zaś ekran jest wyłączony i rozpocznie się takie skanowanie (a przypomnę, że często rozpoczyna się ono ze zwłoką, np. po wyłączeniu ekranu) potrafiące trwać chyba bez końca (nawet kilka godzin wg moich spostrzeżeń), to nie pozwala to na wyłączenie modułu. Po włączeniu ekranu jeszcze przez jakiś czas obserwuję to skanowanie i status modułu WiFi informujący o jego aktywności. Gdy po kilku godzinach włączę ekran, a w międzyczasie rozpoczęło się to auto-skanowanie, to zostaje ono po jakimś czasie ukończone (oczywiście bez rezultatu) i dopiero! wtedy wyłącza się moduł, a jak wiadomo niepotrzebnie zużywa to energię i ogólnie nie jest to pożądane. Czy ktoś wie co zrobić, aby moduł WiFi po spełnieniu warunków aplikacji został przez nią jak najszybciej wyłączony?
x