Skocz do zawartości
Gregs

MOD Uruchomienie ukrytych funkcji w ROM-ach Samsunga

    Rekomendowane odpowiedzi

    acheron

    @seba84_2005

    odstępy były , a ja zrobiłem też dla kodu na mms

    @ Gregs

    tak mms nie przychodzi i żeby pobrać włącz transmisję danych , coś w ten deseń się wyświetla, tak oczywiście permision poprawne , nie mam feature .xml tylko others.xml . ok , sprawdzę ten kod z ''N''

    edit. qrcze ten kod też nie działa właczam NFC i na stsus barze niema "N"

    Edytowane przez acheron

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Gregs

    To niemożliwe. A robiłeś restart telefonu po edycji?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    acheron

    Tak , restartowałem telefon .jak wystarczy tylko włączyć nfc żeby na status bar pojawiło "n" to nie działa

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Gregs

    Tak wystarczy włączyć i momentalnie na belce pokazuje się N. To działa tylko na ROM-ach Samsunga. Na ROM-ach CM nie działa. U mnie NFC działa na SGS2 (I9100P), SGS3 i SGS4.

    Jak masz chęć się jeszcze pobawić, to możesz wejść: system/csc/XEO/system/csc/others.xml i tam wkleić kod.

    Kod wklejony w tym miejscu działa tylko na CSC XEO, a ze screena wiem, że masz XEO.

    Samsung w ten sposób różnicuje dostępne funkcje dla danego kraju.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    acheron

    up

    zrobiłem tak jak napisałeś , wpisałem kod na mms i na ''nfc'' w csc w XEO , po nadaniu uprawnień i restarcie , była nadal lipa czyli nie działało , ale bardzo mi zależało na MMS, dlatego zgodnie z przysłowiem''tonący brzytwy sie chwyta'' , posłużyłem się apką do Nota2 z SP i ruszyło wszystko działa , teraz nie wiem o co ''kaman'' , może w jakiś sposób uaktywniło(przeniosło w odpowiednie miejsce) te kody co wpisałem ręcznie ;) bro..

    edit. porównałem plik others.xml :

    przed uzyciem n2 hide setings

    post-151017-14255729994637_thumb.png

    a tak wygląda po użyciu tej apki:

    post-151017-14255729995171_thumb.png

    w samej apce włączyłem tylko funkcję mms reszta jest wyłączona a mimo to jak włączę NFC to ''N'' sie pokazuje czyli jakoś sie te kody uaktywniły , może komuś się przyda a ja się cieszę że działa pozdro :)

    Edytowane przez acheron

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Aplikacja nadała odpowiednie uprawnienia i to dlatego, Ty pewnie zapomniałeś tego zrobić.

    Wysłane z mojego GT-I9100 za pomocą Tapatalk 2

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    acheron

    up

    we wcześniejszych postach już mnie pytano o to czy nadawałem uprawnienia permission i odpowiedż była twierdząca tak że nie w tym tkwił problem uwierz mi że zanim tutaj napisałem to dokładnie przeczytałem co i jak zrobić i próbowałem na wiele sposobów , tak czy siak działa i oto chodzi:P

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wolfrl

    Ja skopiowałem sobie others.xml na kompa, wkleiłem kod do mmsów, usunąłem oryginalny plik w telefonie i wrzuciłem zmodyfikowany z kompa. Nie zmieniałem uprawnień pliku tylko od razu zrestartowałem telefon i działa :E

    Jak rozumiem, po aktualizacji softu przez OTA trzeba cały zabieg powtórzyć?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Gregs

    Niestety tak. Nowy soft przywraca ustawienia stockowe.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    dest

    dla mnie nie dziala na s4 mini, nie mam pojecia dlaczego

    co ciekawe na note 2 zadziałało odrazu

    uprawnienia są poprawne, sprawdzałem 10razy

    post-52253-14255732352834_thumb.png

    w akcie desperacji wrzucilem do pliku w

    system/csc/XEO/system/csc/others.xml

    post-52253-14255732353315_thumb.png

    nic sie nie zmieniło

    bez wlaczonej transmisji nie odbiera ani nie wysyla mmsow

    gdzie jest blad ?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x