Skocz do zawartości
toruogiwara

Kruger&Mantz LIVE i MOVE - poprawienie działania GPS

    Rekomendowane odpowiedzi

    perssi

    Zrobiłem root ale nijak nie mogłem zastąpic pliku gps.conf (comanderem, rootexplorer i es) uprawnienia były nadane przez supersu, więc zaktualizowałem rom tak jak pisał cichy341 ale takze nie pomogło choc plik gof.com na podgladzie jest taki sam jak od cichy341 a nadal gps pokazuje moją lokalizacje 10 - 20 km ode mnie.. Jest ktoś w stanie pomóc? byłbym wdzięczny..;)

    ---------- Post dołączono o 16:40 ---------- Poprzedni post napisano o 16:28 ----------

    dokładnie tak wygląda plik po zastosowaniu sie do wskazówek cich341:

    #Europe

    NTP_SERVER=pl.pool.ntp.org

    xtra_server_1=http://0.pl.pool.ntp.org

    xtra_server_2=http://1.pl.pool.ntp.org

    xtra_server_3=http://2.pl.pool.ntp.org

    xtra_server_4=http://3.pl.pool.ntp.org

    xtra_server_5=http://0.europe.pool.ntp.org

    xtra_server_6=http://1.europe.pool.ntp.org

    xtra_server_7=http://2.europe.pool.ntp.org

    xtra_server_8=http://3.europe.pool.ntp.org

    xtra_server_9=http://xtra1.gpsonextra.net/xtra.bin

    xtra_server_10=http://xtra2.gpsonextra.net/xtra.bin

    xtra_server_11=http://xtra3.gpsonextra.net/xtra.bin

    # DEBUG LEVELS: 0 - none, 1 - Error, 2 - Warning, 3 - Info

    # 4 - Debug, 5 - Verbose

    DEBUG_LEVEL = 3

    # Intermediate position report, 1=enable, 0=disable

    INTERMEDIATE_POS=0

    # supl version 1.0

    SUPL_VER=0x10000

    # Error Estimate

    # _SET = 1

    # _CLEAR = 0

    ERR_ESTIMATE=0

    # GPS Capabilities bit mask

    # SCHEDULING = 1

    # MSB = 2

    # MSA = 4

    # ULP = 0x20

    # default = MSA | MSB | SCHEDULING | ULP

    CAPABILITIES=0x27

    # Accuracy threshold for intermediate positions

    # less accurate positions are ignored, 0 for passing all positions

    # ACCURACY_THRES=5000

    ################################

    ##### AGPS server settings #####

    ################################

    # FOR SUPL SUPPORT, set the following

    # SUPL_HOST=supl.host.com or IP

    # SUPL_PORT=1234

    # For test use only

    SUPL_HOST=supl.google.com

    SUPL_PORT=7276

    # FOR C2K PDE SUPPORT, set the following

    # C2K_HOST=c2k.pde.com or IP

    # C2K_PORT=1234

    ################################

    # Sensor Settings

    ################################

    # Needs to be set explicitly based on sensor

    # There is no default value.

    #GYRO_BIAS_RANDOM_WALK=

    # Sensor Sampling Rate Parameters for Low-Data Rate Filter (should be greater than 0)

    SENSOR_ACCEL_BATCHES_PER_SEC=2

    SENSOR_ACCEL_SAMPLES_PER_BATCH=5

    SENSOR_GYRO_BATCHES_PER_SEC=2

    SENSOR_GYRO_SAMPLES_PER_BATCH=5

    # Sensor Sampling Rate Parameters for High-Data Rate Filter (should be greater than 0)

    SENSOR_ACCEL_BATCHES_PER_SEC_HIGH=4

    SENSOR_ACCEL_SAMPLES_PER_BATCH_HIGH=25

    SENSOR_GYRO_BATCHES_PER_SEC_HIGH=4

    SENSOR_GYRO_SAMPLES_PER_BATCH_HIGH=25

    # Sensor Control Mode (0=AUTO, 1=FORCE_ON)

    SENSOR_CONTROL_MODE=0

    # Enable or Disable Sensors for GPS use (0=Enable, 1=Disable)

    SENSOR_USAGE=0

    # Choose GSIFF sensor provider (1=DSPS, 2=Android NDK)

    SENSOR_PROVIDER=1

    ################################

    # Indoor Positioning Settings

    ################################

    # 0: QUIPC disabled, 1: QUIPC enabled, 2: forced QUIPC only

    QUIPC_ENABLED = 0

    ################################

    # EXTRA SETTINGS

    ################################

    # Enable or Disable Wiper (1=Enable, 0=Disable)

    ENABLE_WIPER=1

    # NMEA provider (1=Modem Processor, 0=Application Processor)

    NMEA_PROVIDER=0

    ####################################

    # LTE Positioning Profile Settings

    ####################################

    # 0: Enable RRLP on LTE(Default) 1: Enable LPP_User_Plane on LTE

    LPP_PROFILE = 0

    i jak go edytuje i chce zapisac to wyskakuje błąd zapisu do pliku gps..

    Edytowane przez positivepl

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    SamXel
    plik gof.com
    Plik gps.conf

    Wystarczy tylko sam wpis:

    NTP_SERVER=pl.pool.ntp.org
    xtra_server_1=http://0.pl.pool.ntp.org
    xtra_server_2=http://1.pl.pool.ntp.org
    xtra_server_3=http://2.pl.pool.ntp.org
    xtra_server_4=http://3.pl.pool.ntp.org
    xtra_server_5=http://0.europe.pool.ntp.org
    xtra_server_6=http://1.europe.pool.ntp.org
    xtra_server_7=http://2.europe.pool.ntp.org
    xtra_server_8=http://3.europe.pool.ntp.org
    xtra_server_9=http://xtra1.gpsonextra.net/xtra.bin
    xtra_server_10=http://xtra2.gpsonextra.net/xtra.bin
    xtra_server_11=http://xtra3.gpsonextra.net/xtra.bin
    SUPL_HOST=supl.google.com
    SUPL_PORT=7276
    C2K_HOST=default
    C2K_PORT=0

    Plik zamieniłem apką Root Explorer

    ES File Explorer mi się nie udawało.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    perssi

    zrobiłem unroot, potem ponownie root i comander poradził sobie ze zmianą pliku gps.conf ale u mnie nawigacja nadal jest niedokładna o jakies kilka km.. no ale cóz, moze dlatego ze na wsi a:D

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    SamXel

    Zrestartowałeś smarta ?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    perssi

    oczywiście :)

    ---------- Post dołączono o 22:33 ---------- Poprzedni post napisano o 22:25 ----------

    jutro szykuje mi sie dłuzsza trasa więc wypróbuje jak jest w praktyce a:P

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    SamXel

    Zainstaluj apke GPS Data (płatny GPS Data+) wyjdź na zewnątrz i postój trochę pod chmurką.

    https://play.google.com/store/apps/details?id=com.pierwiastek.gpsdata

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    U mnie po edycji tego pliku telefon przestał znajdować fixa :/.

    Najlepsze jest to, że po przywróceniu oryginalnego pliku dalej nie łapie (tak robiłem restart).

    EDIT

    Po którymś restarcie zaczęło działać i łapie sygnał bardzo szybko - ok. 40s , a wcześniej ok 5-6 min czekałem.

    Edytowane przez zawada124

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    taida5

    U mnie (tel. Krüger&Matz LIVE) po zainstalowaniu Faster GPS sygnał łapie po 15 sek.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Mokry

    A u mnie po aktualizacji softa do 1.4, bez tego badziewia łapie mi fix z 4 sekundy...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x