Skocz do zawartości
szymel00

Szybka i łatwa metoda portowania ROM-u

    Rekomendowane odpowiedzi

    Zrób i sprawdź logcat z bootowania.

    Jak zrobić logcata z bootowania? Standardowe $adb logcat przy bootowaniu pokazuje mi "- waiting for device -"

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    maxprzemo

    Czym ta metoda różni się w przypadku MIUI V5 ?

    Bo z tego co widzę to jest tu chyba podana metoda dla MIUI V4 a ona nie chce mi niestety zadziałać przy próbie zrobienia portu MIUI V5 na mój telefon czyli Ace 2 ?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    szymel00

    Miuiv5 również udało mi się przeportować tą metodą. ;)

    Wysłane z mojego LG-P700 przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    maxprzemo

    A co z plikiem invoke-as z system/xbin/ bo w rzadnym porcie V5 jaki przegladalem go nie ma ?

    A plik su z /xbin podmieniales ?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    @Mateusz Flasiński

    Debugowanie przy bootowaniu trzeba włączyć. Najczęściej wystarczy dodać ",adb" do buildprop w linijcie gdzie masz typ połączenia usb, np "mtp"

    Jeśli nadal nie działa do trzeba ro.secure zmienić w kernelu (patrz poradniki dla miui które podałem wyżej)

    A tutaj dodatkowy poranik dla telefonów sony:

    (chodzi o blokade telefonu po której cała płyta główna jest do wymiany)

    http://forum.xda-developers.com/showthread.php?t=2475352

    Edytowane przez LukaszK
    Sprawy prywatne, tak jak sama nazwa wskazuje, załatwiamy prywatnie.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wdarku

    Chce zrobić pierwszy custom rom dla Alcatela 6030x.

    Aby zacząć muszę mięć obraz softu który posiadam problem w tym iż tam nie ma folderu init.d

    A to co mamy :

    post-113393-14255739640395_thumb.jpg

    post-113393-14255739640554_thumb.jpg

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    adek89

    robie wedlug poradnika rom sie wgrywa odpala pokazuje sie launcher a po 2 sek reboot i tak w kolo

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mattek

    Hej.

    Z racji tej, iż na moją Mango nie ma idealnego ROMu, postanowiłem, że przeportuję sobie Gin2KitKat z Xperii Neo V. Za podstawkę wziąłem sobie stockowy firmware .84, który został oczyszczony ze zbędnych aplikacji i przekonwertowany do tzw. flashable zip przez pewnego usera XDA. Kierując się tym poradnikiem przystąpiłem do pracy, a następnie zdecydowałem się przetestować to, co upiekłem. Soft ładnie się sflashował, załadował i bardzo się ucieszyłem, ponieważ pojawił się home screen. Niestety, radość nie trwała długo, ponieważ po włączeniu się telefonu i pojawieniu ekranu głównego, mijają jakieś trzy sekundy i telefon łapie freeze, a następnie resetuje się.

    Czy moglibyście mi pomóc rozwikłać ten problem? Z resztą czyli poprawianiem ikonek myślę, że chyba sobie poradzę, jednak nie umiem ogarnąć tego buga. Chętnie zamieściłbym logi, ale jak włączyć debugowanie, skoro system zaraz się restartuje?

    Czekam na Wasze propozycje ;)

    UPS, chyba zły dział :/

    Edytowane przez Dzakus
    Notatka moderatora zbędna

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jest możliwość przeportowanie romu tylko dla odblokowanego bootlodera na.zablokowanego?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    adek89
    Hej.

    Z racji tej, iż na moją Mango nie ma idealnego ROMu, postanowiłem, że przeportuję sobie Gin2KitKat z Xperii Neo V. Za podstawkę wziąłem sobie stockowy firmware .84, który został oczyszczony ze zbędnych aplikacji i przekonwertowany do tzw. flashable zip przez pewnego usera XDA. Kierując się tym poradnikiem przystąpiłem do pracy, a następnie zdecydowałem się przetestować to, co upiekłem. Soft ładnie się sflashował, załadował i bardzo się ucieszyłem, ponieważ pojawił się home screen. Niestety, radość nie trwała długo, ponieważ po włączeniu się telefonu i pojawieniu ekranu głównego, mijają jakieś trzy sekundy i telefon łapie freeze, a następnie resetuje się.

    Czy moglibyście mi pomóc rozwikłać ten problem? Z resztą czyli poprawianiem ikonek myślę, że chyba sobie poradzę, jednak nie umiem ogarnąć tego buga. Chętnie zamieściłbym logi, ale jak włączyć debugowanie, skoro system zaraz się restartuje?

    Czekam na Wasze propozycje ;)

    :/

    mam tak samo jak zrobię port semc z x8. jakieś pliki się gryza

    Wysyłane z mojego WT19i za pomocą Tapatalk 2

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x