Skocz do zawartości
mnl187

Recovery nie ładuje CACHE - sposob naprawy

    Rekomendowane odpowiedzi

    mnl187
    Napisano (edytowane)

    Witam,

    postanowilem wrzucić dziś Rom Pay'a i postępując zgodnie z instrukcją wszystko przebiegło normalnie i sprawnie.W momencie gdy chciałem pobrac aplikację (jakąkolwiek) z marketu wyskakiwał komunika

    "pobieranie nie powiodło się" po czym pojawiała się ikona pobierania, komunikat że pobiera, 2 sekundy później pasek postępu zanikał i nazwa aplikacji pojawiała się w pobranych niestety jako niezainstalowana.

    Reinstalacja vending.apk w system/app podobnie nie przyniosła pozytywnych rezultatów.

    Postanowiłem zrobić wtedy wipe data i cache i jakie było moje zdziwienie gdy w recvery wywaliło mi błąd:

    - E: Can't mount /dev/block/mmcblk1p24

    (Invalid argument)

    - E: Cant' mount CACHE: recovery/command

    - E: Can't mount CACHE: recovery/log

    - E: Can't open CACHE: recovery/log

    wipe data kończy się bezproblemowo natomiast cache'u nie chce wyczyścić.

    Wgrywałem juz różne romy Froyo i na żadnym nie chce hulać tak jak dawniej.

    Czy ma ktoś może jakieś pomysły co zrobić żeby naprawić te błędy??

    Edytowane przez sp4ubw
    Zmiana tematu

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    veimus

    Może ponowny flash ROMu ? albo na początek wgraj na nowo recovery.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mnl187
    Napisano (edytowane)

    Tak jak napisałem, wgrywałem (flashowałem) już naście razy wgrywając 2 różne recovery i za każdym razem jest to samo.

    Btw. w recovery/Mount and Storage Menu są do wyboru po koleji opcje ładowania i formatowania.

    Tylko w 2 przypadkach nie da się zakończyc poprawnie akcji (mount/format) - cache i sd-ext.

    Przewertowałem google i na jakimś hiszpańsko-języcznym forum

    też padlo pytanie o naprawę błędu, ale u mnie zatrzymuję się na jednym kroku bo nie da się wykonać wpie'u z poziomu telefonu.

    Moge wciskać i wciskać , a on dalej nie zaskakuje.

    Ostatecznym wyjśce jest chyba podmiana plików więc jakby się znalazł ktoś uprzejmy i skopiował dla mnie katalog /dev/block to w dowód wdzęczności postawię browarka ;]]

    EDIT:

    Niestety muszę zmartwić wszystkich chętnych na darmowe trunki niskoprocentowe.

    Przyznam, ze kombinowałem dziś dość długo jak do tego dojść i dalej nie jestem w 100% przekonany dlaczego wszystko wróciło do normy.

    Przedstawię krótki tutorial dla potomnych :]

    - instalacja czystego Romu JRDNEM_U3_3.4.2_145-003_DEBLUR

    - wchodzimy w standardowe recovery (power+vol down) następnie przytrzytmujemy przyciski głośności -> pojawia sie menu recovery (wywalał błąd ładowania Cache'u)

    - wybieramy wipe data , potem wipe cache

    - reboot

    - wchodzimy w ustawienia/privacy/ robimy reset ustawień fabrycznych (wcześniej nie mogłem tego zrobic)

    - teraz sprawdziłem i okazalo się że market śmiga az miło, więc dla pewności wrzuciłem jeszcze raz JRDNEM_U3_3.4.2_145-003_DEBLUR

    - root, ClockworkMod Recovery v2.5.1.8 (po tym wrzuciłem root explorera żeby posprawdzać wadliwe pliki, defakto nic nie zrobiłem poza właczeniem mount R/W)

    - reboot do recovery i ..... WOW wszystko działa jak należy ;]

    Edytowane przez mnl187

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    SnaQ

    Właśnie spotkało mnie to samo z tym, że w moim przypadku przyczyną była zapewne próba powrotu do 2.51. Z marketu nic mi się nie ściąga, nie mogę zrobić wipe z poziomu menu, recovery wywala identyczne błędy. Mam nadzieję, że Twoje rozwiązanie pomoże...

    EDIT: Jest dobrze (chyba) bo market już śmiga :) Piwko leci.

    Edytowane przez SnaQ

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    BRAVO PVT4 SHIP S-ON

    HBOOT-0.93.0001

    MICROP-051d

    TOUCH PANEL-SYNT0101

    RADIO-5.11.05.27

    Aug 10 2010,17:52:18

    -----------------------------------

    Mam następujący problem:

    po wykonaniu root i wejściu w recovery (ClockworkMod recovery v2.5.0.7)

    komunikat:

    E:Can't find MISC:

    E:Can't mount CACHE:recovery/command

    E:Can't find MISC:

    E:Can't mount CACHE:recovery/log

    E:Can't find MISC:

    Ponadto brak opcji partition, brak możliwości wipe data i cache (error), oraz brak możliwości hard reset z telefonu.

    Nie można też wykonać backup z boot.

    backing up boot...

    Error while dumping boot image!

    E:Can't mount CACHE:recovery/log

    E:Can't find MISC:

    Proszę o pomoc co z tym robić.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    sp4ubw

    matthew28, Defy nie miała wersji 2.5.0.7. Zaczęło się od 2.5.1.2 GoAPK. A ty nam wkleiłeś dane z Desire, a nie z Defy. Czyżby kolega jeszcze nie był trzeżwy po świętach?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    myślałem że może jakąś odpowiedz tu znajdę.

    w zasadzie to we wszystkich androidach jest podobnie i błąd w recovery wywala z podobnego powodu .

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.