Skocz do zawartości
tolaz

[Poradnik] Naprawa błędu can't mount /data

    Rekomendowane odpowiedzi

    tolaz

    A kartę masz formatowaną w Recovery czy sam ją sobie formatowałeś na kompie?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Clear

    Po zainstalowaniu drugiego systemu z Sepamhore 2.7.4 (dopiero tam jest opcja zrobienia partycji dla karty) jeszcze na starej karcie, wyłożyłem starą kartę, włożyłem nową i zrobiłem partycję tak, jak to jest opisane w pierwszym poście.

    A kiedy posiadałem jeszcze starą kartę to robiłem partycję na kompie, bo z oczywistych względów na telefonie się nie dało (nie wchodził w ogóle do Recovery), ale po dojściu do instalacji Semaphore 2.7.4 i zrobieniu wtedy przez Recovery od nowa partycji wszystko działo się wtedy identycznie jak z partycją robioną na kompie.

    A jeszcze takie pytanie: czemu po wrzuceniu CMa na kartę i wejściu w Recovery przed instalacją CMa trzeba zrobić Wipe? Przecież Wipe usuwa wszystkie dane z telefonu, przez co, kiedy go zrobiłem nie chciało znaleść żadnych plików na karcie (wyskoczył jakiś błąd, że nic nie ma), dopiero za drugim podejściem nie robiłem Wipe i wtedy dopiero znalazło plik z systemem i zainstalowało jak zainstalowało, bo i tak nie chce się włączyć do końca.

    Edytowane przez Clear

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    tolaz

    Dziwne że u innych działa a u Cb nie. Wipe nie rusza przecież karty pamięci... Wipe usuwa dane użytkownika zapisane w telefonie czyli aplikacje etc a karta pamięci zostaje nie tknięta. A skoro nie zrobiłeś wipe to możliwe że przez to Ci nie odpala

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Clear

    No ale po zrobieniu wipe nie widzi żadnego katalogu w pamięci (no files found). Jeśli nie zrobię wipe to można wejść w wybieranie systemu do zainstalowania (ale chyba wybiera się z partycji systemowej, a nie z karty pamięci)[EDIT: po wejsciu w external SD wyświetla tam pliki z pamięci karty]. Czy przy przechodzeniu z tego CMa znowu na ten pierwszy system z poradnika muszę zaznaczać repartition?

    Dziwi mnie to, że po wyjęciu karty telefon działa. Przecież system jest zainstalowany ka partycji na karcie (chyba, że coś pomieszałem i u mnie jest inaczej).

    EDIT: Postanowiłem wgrać wszystko od totalnego początku.

    Napiszę, co robiłem:

    1. Wyłożyłem kartę pamięci, wgrałem stockowego normalnego Androida 2.3.6 - oczywiście nie włączył się - bootloop (zamiennie pokazuje czarny obraz i "Galaxy S"). Przy instalacji zaznaczyłem Re-partition.

    2. Wgrałem Semaphore 2.7.4 .

    3. Włożyłem kartę pamięci, skorzystałem z poradnika

    Dzielimy kartę na dwie partycje 2GB EXT2/ext3/ext4 a resztę pamięci w fat32.Najlepiej to zrobić wchodząc w Recovery->advaced->partition SD card i ustawić ext na 2048 a swap na 0

    4. Potem wszystko według poradnika, czyli:

    Włączamy program Odin i wybieramy PIT 512 ten który jest w paczce następnie ustawiamy następująco pozostałe pola:

    PDA: XXJVU_sdcard_v1_3_1.tar

    PHONE: PHONE_XXJVU.tar

    CSC: CSC_OXAJVU_Modified.tar

    Odznaczyłem Re-partition i wgrałem.

    Po wejściu w "Pamięć" pokazywało :

    - Karta SD - nic

    - Pamięć USB - 12.92GB (dostępne 12.91GB)

    - Pamięć urządzenia - 1.78GB

    5. Wyłączyłem telefon, wgrywam drugi system z poradnika:

    PIT: Taki jak był wcześniej

    PDA: PDA_I9000XWJW9.tar

    PHONE: PHONE_I9000XWJW1.tar

    CSC: CSC_I9000OXAJW4.tar

    ODZNACZAMY REPARTITION i flashujemy soft po czym powinien telefon się włączyć a my go jeszcze raz wyłączamy i znów wchodzimy w tryb download.

    6. Wgrałem Semaphore 2.7.4 zgodnie z poradnikiem:

    W Odinie ustawiamy tylko PDA: Semaphore_2.7.4 bez PIT.

    7. Po wgraniu i wejsciu w "Pamięć" pokazuje:

    - Karta SD - nic

    - Pamięć USB - nic

    - Pamięć urządzenia - 1.87GB

    8. Nie mogę nic wrzucić na pamięć karty SD, ponieważ Windows nie widzi w ogóle telefonu (gdy w telefonie jest widoczna karta pamięci, wtedy w komputerze pojawia się ikonka "Phone" - jest dostępna karta pamięci i chyba partycja systemowa). Jest tylko dźwięk podłączania urządzenia.

    Teraz, gdy wyjmę kartę pamięci to telefon nie włącza się - bootloop.

    Niedługo po prostu rzucę tą cegłą o ścianę i nie będzie czego zbierać. Nie mam już do niego cierpliwości...

    Po wejściu do Recovery po zainstalowaniu drugiego systemu + Semaphore da się zainstalować CM11, ale ze skutkiem takim, jak wcześniej. Nie wiem w ogóle, jak może być widoczny tel plik z systemem CM11, bo przeciez formatowałem kartę tworząc partycję przez telefon i nie powinno go być, a jest to plik, który wgrałem kilka dni temu...

    Gdy zaś Recovery od CM11 wejdę w "Mounts and Storage Menu" nie mam wszystkiego zamontowanego (niezamontowane to: "/datadata", "/system", "/data", "/storage/sdcard0" "USB Storage"), kiedy chcę zamontować je to "/datadata" się montuje, natomiast przy reszcie wyskakuje błąd "Error mounting" .

    Edytowane przez Clear

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    tolaz

    Zaraz po sformatowaniu karty wrzuć na nią plik z CM11 i wtedy rób już tak jak w poradniku i powinno wskoczyć. A po wgraniu Semaphore spróbuj wejść odrazu w Recovery zaraz po tym jak tryb download się wyłączy i telefon bd się chciał włączyć to wtedy wejdź w Recovery i zainstaluj CM

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Clear

    Ale po formacie nie będę miał w ogóle systemu, wiec jak wrzucę plik z CM na telefon bez systemu?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    tolaz

    Nie rozumiem tego co napisałeś :P Jak to nie bd miał systemu? Bd miał najpierw 2.3.6 z semaphore a później po wipe bd miał CM11

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Clear

    A o jaki format chodzi, bo może ja źle zrozumiałem :P? Jeśli chodzi o stworzenie partycji od nowa to przecież karta się wyczyści, a razem z nią system. A bez systemu na telefonie nie dostanę się poprzez komputer do pamięci karty, co uniemożliwia skopiowanie pliku z CM11 z komputera na pamięć karty pamięci.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    tolaz

    Poprostu weź teraz wejdź w Recovery i sformatuj kartę tak jak pisze w poradniku następnie jak masz czytnik kart to wrzuć na czystą kartę CM a jeśli nie masz to zainstaluj zmodyfikowany rom JVU i jak się włączy telefon to przez kabel prześlij CM na pustą kartę następnie wgraj JW4 po czym semaphore i wejdź w recovery i wgraj tego CM którego masz na karcie i tylko tyle ale to wszystko pisze w poradniku.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Clear

    ale tak sformatowana karta wrzucona do adaptera i podłączona pod czytnik kart nie chciała być widoczna w Windows (sprawdzałem przedtem z poprzednią karta), ale spróbuję jeszcze raz z ta karta.

    ---------- Post dołączono 19-02-14 o 18:38 ---------- Poprzedni post napisano 18-02-14 o 21:02 ----------

    Nadal to samo. Telefon z działającym 2.3.6 chyba wyląduje na allegro.

    ---------- Post dołączono 20-02-14 o 08:10 ---------- Poprzedni post napisano 19-02-14 o 18:38 ----------

    A mogę zainstalować jakiegoś innego, nowszego Androida - niekoniecznie Kitkata?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x