Skocz do zawartości
moonraker

Lampa aparatu wyłącza telefon

    Rekomendowane odpowiedzi

    Witam.

    W przeciągu paru dni będę się żegnał z moim sensation na rzecz nowszego następcy. HTC chciałbym sprzedać tylko że występuje w nim pewien problem. Obecnie mam wgrany CM11 na andku 4.4.2 i ogólnie trzeba powiedzieć, że to najlepszy rom jaki miałem na tym htc, szybkość działania jest świetna, nie ma się do czego przyczepić. Problem pojawia się tylko gdy chce się zrobić zdjęcie z flashem. Otóż świeżo odłączony od ładowarki przez kilka godzin przeważnie da się takie zdjęcie zrobić. Później, gdy bateria zejdzie ponizej tych 90-80% próba zrobienia zdjęcia z flashem skutkuje wyłączeniem telefonu (natychmiastowym, jakbym baterię wyjął) i co gorsze telefon nie chce się ponownie uruchomić do czasu aż się nie wyciągnie i nie wsadzi z powrotem baterii. Ten problem występuje już długo, praktycznie zaczęło się po niecałym roku używania. Zacząłem wstawiać między baterią a telefonem wstawki z papieru itp żeby docisnąć baterię do styków. Na początku coś to faktycznie dawało, ale później wróciło to samo. Około pół roku temu kupiłem nową baterię (wersję mocnejszą przeznaczoną dla EVO 3D, oryginał HTC) i fakt faktem, że czas trzymania na baterii poprawił się ogromnie (telefon spokojnie trzyma 40h) ale nie pomogło to jeśli chodzi o problem z flashem. I teraz przyszło go sprzedać, ale nie chcę mieć zwrotów za chwilę z tego tytułu więc moje pytanie jest takie - czy ktoś zna przyczynę tego co opisałem? IMO chodzi o to, że przy użyciu flasha przepływa zbyt duży prąd przez coś i powoduje zadziałanie jakiegoś bezpiecznika. Ale być może przyczyna jest inna i ktoś wie jaka. Może istnieje rom w którym dało by się zmniejszyć moc flasha? (Dioda używana jako latarka działa bez problemu i nic się nie dzieje, nawet pół godziny może świecić, telefon się nagrzeje ale nic się nie wyłącza - tylko, że wtedy moc jest dużo mniejsza niż w momencie błysku aparatu)

    Pozdrawiam i czekam na jakieś wskazówki

    Edytowane przez moonraker

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    AS0

    Może spróbuj wgrać oryginalne oprogramowanie albo ROM oparty na oryginalnym oprogramowaniu i sprawdź czy problem nadal występuje :P

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Tak planuję zrobić i chyba nawet jutro, bo nowy G2 juz dojechał wiec moge zaczac operowac htc'ka. Myślałem może, że to bardziej powszechny problem bo imo jest to jakas wada produkcyjna (a raczej błąd czy niedopatrzenie przy projektowaniu). No nic dam znac czy udalo mi sie to rozgryźć.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Dario

    Problem jest bardzo powszechny :)

    ale ciężko o rozwiązanie, najczęstszym podejrzanym jest bateria poniżej chyba 30%, ale u mnie np. jest nowa bateria i prawie na każdym ROMie z różnymi kernelami występuje ten problem. Niekiedy zrobię 2-3 zdjęcia z lampą a następne wyłączy telefon, czasem od razu się wyłączy.

    sam chętnie poznam rozwiązanie zagadki ;]

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    O widzę że wymiana baterii nie koniecznie naprawia tą usterke, też będę wdzięczny jakby ktoś podzielił się rozwiązaniem tego problemu

    Wysłane z mojego HTC Sensation Z710e przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Dario

    jest też opcja, że mogę mieć walniętą baterię :)

    kupiłem nową oryginalną ale kto wie czy nie trafiłem na jakiś feler.

    ale z drugiej strony mój tel zaliczył multum upadków z różnych wysokości i na różne twarde rzeczy, że też mogło coś się uszkodzić.

    ale na XDA zwracali uwagę głównie na baterię

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    No więc wgrałem CM 9.1 stable android 4.0.4 ICS iiii... działa ;) Zrobiłem z 20 zdjeć z lampą pod rząd przy 70% baterii i wszystko śmiga, nic się nie wyłącza. Czyli jednak to kwestia programowa. Być może przy CM11 i na innych romach w których to wystepuje programiści użyli jakiegoś innego źródła które np próbuje wydusić mocniejsze światło z tych diód i kończy się tak jak opisałem w poście nr1. W każdym razie mój problem jest rozwiązany, dziękuję za uwagę. Decyzję o zamknięciu pozostawiam moderatorowi.

    Pozdrawiam

    -----edyta-----

    W związku z pytaniem które otrzymałem na PW włączyłem sensację nieużywaną 3 dni z baterią 77% żeby potwierdzić działanie aparatu z lampą i niestety muszę poinformować zainteresowanych, że znowu się wyłączyła. Na tą chwilę nie mam już kompletnie pojęcia o co tu chodzi.

    Edytowane przez moonraker
    uaktualnienie

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x