Skocz do zawartości
K___

"appcompat_v7" - co to takiego?

    Rekomendowane odpowiedzi

    K___

    Witam

    To mój pierwszy post na tym forum, dlatego korzystając z okazji chciałem się ze wszystkimi przywitać. Czytam forum od dłuższego czasu, teraz mam w planach troszkę aktywniej uczestniczyć w tutejszym życiu :)

    Od wczoraj mam problem z Eclipse - tworząc jakąkolwiek aktywność do projektu dodawana jest zewnętrzna biblioteka (?) o nazwie "appcompat_v7", która wywala całą masę błędów. Wygląda mi to na zapewnienie kompatybilności wszystkich wersji, niestety na moim etapie nauki nie jestem w stanie uporać się z błędami które w niej występują.

    Stworzenie nowego projektu bez żadnej aktywności nie generuje tej biblioteki, ale już dodanie aktywności do projektu wywala całą pracę. Myślałem że ja coś zepsułem, więc przeinstalowałem Eclipse'a na nowo, skasowałem nawet starsze programiki szkoleniowe, ale nic to nie dało. W zasadzie nie jestem w stanie zrobić absolutnie niczego.

    Dodam, że tworzę (staram się) aplikacje dedykowane dla wersji 4.4, z minimalną wersją 2.2.

    Będę wdzięczny za wszelką pomoc i sugestie. Wielkie dzięki :)

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    K___

    Czyli jedynym wyjściem jest robienie aplikacji nie działających na starszych urządzeniach, mimo że nie wykorzystuję (chyba) żadnych elementów z najnowszych wersji? Mam wrażenie, że mija się to z całą ideą tego systemu...

    Inna sprawa, że mam to od wczoraj. Wcześniej nie było potrzebne?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    asmok

    Zrób projekt tylko dla jednej wersji np 4.1, powinien się wygenerować bez appcompat. Po wygenerowaniu projektu w manifeście sobie zmień minimalną na 2.2. Będziesz miał to co chcesz.

    W zasadzie jedyną różnicą jaką widzę przy używaniu appcompat jest używanie ActionBarActivity który powoduje że ActionBar wygląda działa w 2.x tak samo jak w 4.x.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x