Skocz do zawartości
przemvelbenny

stock [STOCK RECOVERY] myPhone Luna Amigo UI - stockowy ROM i RECOVERY

    Rekomendowane odpowiedzi

    wraven
    link tyle udało mi się wytargać luny (ofc revcovery to phill czy jakos tak) mtk droid tools ma opcje przerobienia dp spf. Trzeba dodać brakujące img bo nie ruszy lub w scatter zamiast nazwy dać NONE o ile pamietam
    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Szczerze mówiac, to nie do końca jeszcze wiem o co chodzi... Ale zaraz będę działał. Najwyżej dopytam. Dzięki.

    Edit:

    Hmmm... Na razie po prostu sflashowałem to, co mi podałeś. Poszło bez problemu (sam proces flashowania). Wiele to nie dało, jak na razie.

    MTK Tools, pomimo zrootowanego systemu i przyznania praw dla 'shell' w aplikacji supersuera, nie jest w stanie uzyskać pełnego/permanentnego roota. W MTK można zmienić IMEI, niestety bez pełnych uprawnień root jest to niemożliwe :(

    @romaro1

    IMEI nie mogę zmienić, bo wyskakuje komunikat "This command is not allowed in UserBuild".

    Edytowane przez przemvelbenny

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wraven

    po sflashowaniu ta paczka, zainstaluj/przywróć rom z recovery jakiś z bekapu.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    romaro1

    IMEI nie mogę zmienić, bo wyskakuje komunikat "This command is not allowed in UserBuild".

    Częsty błąd a chodzi o spacje w komendzie po AT

    AT+EGMR=1,7,"IMEI_NUM_HERE"

    the normal AT command above doesn't work.. it gives an error report like this:

    "this AT command is not valid for UserBuild"

    instead of the success report of:

    "AT COMMAND sent"

    Why?

    i found that there must be a space between T and + in the code.so make sure the code is like below and it will definitely work:

    AT +EGMR=1,7,”IMEI_num_here”

    (do you see the space now?)

    all applications and most write-ups online do not include the space! so when you get to that AT page

    make sure you insert the "space" by yourself...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wraven

    W build.prop "ro.build.type=user" wybiera się eng lub user lub user-debug

    powinno załatwić sprawe braku upawnień

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    IMEI nie mogę zmienić, bo wyskakuje komunikat "This command is not allowed in UserBuild".

    Częsty błąd a chodzi o spacje w komendzie po AT

    AT+EGMR=1,7,"IMEI_NUM_HERE"

    the normal AT command above doesn't work.. it gives an error report like this:

    "this AT command is not valid for UserBuild"

    instead of the success report of:

    "AT COMMAND sent"

    Why?

    i found that there must be a space between T and + in the code.so make sure the code is like below and it will definitely work:

    AT +EGMR=1,7,”IMEI_num_here”

    (do you see the space now?)

    all applications and most write-ups online do not include the space! so when you get to that AT page

    make sure you insert the "space" by yourself...

    Aplikacja MTK Engineering, po wpisaniu pierwszej litery (czyli '+'), sama podpowiada co wpisać poprzez pokazanie wysuwanej listy wyboru. Nam pozostaje jedynie wpisać IMEI pomiędzy dwoma znakami "". Nigdy nie wpisywałem tego ręcznie. Nie zwróciłem uwagi, czy tam jest spacja, czy też nie. Ale dzięki za podpowiedź, może pomoże w przyszłości (aktualnie wszystko działa ok?).

    @warven

    Zauważyłem, że bardzo duże znaczenie ma kolejność wykonywania operacji. Już ładnych kilka razy flashowałem telefon, a potem przywracałem swój backup i było źle. Wczoraj zrobiłem to jakoś tak, że po restarcie nadal jest wszystko OK i system widzi prawidłowe IMEI (te z backupu). Procedurę wykonałem mniej więcej tak:

    • flash stocka od Gionee (od razu z logo.bin od Luny i recovery od PhilZ'a)
    • pierwsze uruchomienie do pokazania się pulpitu, potem wyłączenie telefonu
    • odpalenie recovery od PhilZ'a
    • z menu 'Wipe and Format Options' przeprowadzenie 'Clean to install a New ROM'
    • chyba także zrobiłem wyczyszczenie z poziomu pozostałych opcji - factory reset, wipe cache, wipe dalvik/art cache
    • przywrócenie swojego backupu ze stock romem
    • restart

    Nie wiem dlaczego, ale wydaje mi się, że bardzo duże znaczenie miało pierwsze uruchomienie systemu po zainstalowaniu romu (jeszcze przed przywróceniem mojego backupu) oraz późniejsze wykonanie formatu partycji /system ('Clean to install a New ROM'). To słuszne spostrzeżenie? A jeżeli tak, to dlaczego tak się dzieje?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    romaro1

    Przed wgraniem nowego systemu robię wipe, delvic i dopiero 'Clean to install a New ROM'. Po wgraniu nowego romu czy przywróceniu z backupu robię wipe delvik i cache.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Potem spróbuję jeszcze raz, co i rusz robiąc wszystkie możliwe wipe'y po drodze. Może jakieś sieci gdzieś się zapodziały i one miały wpływ na błędy w systemie.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    romaro1

    Nie tyle zapodziały, co zostały śmieci z poprzedniego romu. Naprawdę, częste problemy z wadliwie działającymi romami wynikają z niepełnego wyczyszczania danych poprzedniego systemu.

    Gdy zmieniałem kernele na htc największą bolączką CWMa były vipy. Nie dawał sobie rady, dlatego używało się dodatkowych scryptów czyszczących. CWM jest dobrym narzędziem ale mimo wszystko uniwersalnym i przez to czasami zawodzącym.

    Zauważyłeś jaka jest różnica czasu w wykonywaniu przez phila samego vipe cache, a całej procedury 'Clean to install a New ROM'?

    Edytowane przez romaro1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Podczas 'Clean to install New ROM' czyści on podstawowe rzeczy, czyli na pewno cache i coś tam (nie pamiętam, ale chyba /data, /cache, powinien też dalvika), a dodatkowo robi format /system. Jeżeli o to Ci chodzi :) Na moim starym telefonie, na którym zaczynałem przygodę z rootowaniem i i wgrywaniem custom romów (ZTE Blade III) trzeba było o tym pamiętać i robić to 'z palca'.

    ---------- Post dołączono o 22:44 ---------- Poprzedni post napisano o 21:56 ----------

    Czy ktoś posiada jeszcze stockowy (oryginalny), zrootowany (z uprawnieniami admina) system od Luny wraz ze stockowym (oryginalnym) recovery? Jeżeli tak, to prosiłbym, żeby zainstalował [ROOT] Rashr - Flash Tool i zrobił kopię recovery, a następnie tutaj podlinkował.

    Robi się to tak:

    - instalujemy Rashr z marketu

    - uruchamiamy Rashr

    - nadajemy mu uprawnienia root

    - przy pierwszym uruchomieniu Rashr pyta, czy wykonać kopię zapasową - oczywiście TAK

    - przeklikać ekrany z kopią zapasową (backup'em) kernela i czymś tam innym - zrobić jedynie kopię recovery

    - backup recovery będzie znajdował się na karcie pamięci w katalogu 'Rashr'

    - wrzucić na jakąś stronkę

    - podlinkować tutaj

    Z góry dziękuję! :)

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x