Skocz do zawartości
dragus1208

tutorial Oblokowanie BOOTLOADERA | ROOT | Custom Recovery - TUTORIAL

    Rekomendowane odpowiedzi

    log102

    A  można w jakiś sposób pozbyć się komunikatu o odblokowanym BL? Pamiętam, że na Moto G LTE podmieniało się odpowiedni plik. Dodam, że wgrałem Lineage OS.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    dzidexx

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Nie mogę odblokować BOOTLOADERA.

    W 11 punkcie po wpisaniu:

    Cytuj

    fastboot oem unlock KOD

    Wyskakuje mi:

    Cytuj

    (bootloader) slot-count: not found
    (bootloader) slot-suffixes: not found
    (bootloader) slot-suffixes: not found
    ...
    (bootloader) Check 'Allow OEM Unlock' in Developer Options.
    FAILED (remote failure)
    finished. total time: 0.012s

    Później wpisuje:

    Cytuj

    fastboot reboot

    i telefon normalnie się uruchamia...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    log102

    @pablo183 " (bootloader) Check 'Allow OEM Unlock' in Developer Options. "  Musisz wejść w opcje programisty i włączyć debugowanie USB  oraz "Zdjęcie blokady OEM". Opcje programisty włączasz wchodząc w ustawienia> informacje o telefonie i na samym dole masz "Numer kompilacji" Tam klikasz szybko kilkukrotnie aż pojawi się napis, że jesteś programistą. 

    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    @up mam włączone debugowanie USB ale nie miałem  Zdjęcie blokady OEM

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    @pablo183  Zdjęcie blokady OEM jest ciut wyżej, mogłeś to przeoczyć.

     

    mam pytanie odnośnie bootloadera. Możemy go odblokować, ale czy można go ponownie odblokować?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    log102

    Akurat co do zablokowania to ja mam bardzo dziwny problem. Krótko mówiąc nie mogę z powrotem zablokować bootloadera :o   komendy " fastboot oem lock begin " oraz " fastboot oem lock." Podczas flashu nic nie dają. Wyskakują mi jakieś dziwne komunikaty w ADB i ani system się nie wgrywa (pozostaje ten z odblokowanym BL) ani nie blokuje się BL.  Dodatkowo gdy chce naładować telefon wyłączony, podpinając go pod ładowarkę pojawia się fastboot mode :o    A komunikaty podczas wgrywania to np.  

    "

    C:\Users\******\Desktop\XT1562_LUX_RETEU_6.0.1_MPD24.107-52.xml>fastboot flash system system.img_sparsechunk.0
    (bootloader) slot-count: not found
    (bootloader) slot-suffixes: not found
    (bootloader) slot-suffixes: not found
    (bootloader) has-slot:system: not found
    target reported max download size of 268435456 bytes
    sending 'system' (262142 KB)...
    OKAY [  9.260s]
    writing 'system'...
    (bootloader) Invalid signed image
    (bootloader) Preflash validation failed
    FAILED (remote failure)
    finished. total time: 9.797s

    "   

     I tak w kółko, oczywiście wcześniej są nazwy wgrywanych innych plików  ale nie będę robił tu spamu. 

     

     

     

     

     

     

    **EDIT: Udało mi się uporać z problemem.  

     

    Aby zablokować Bootloader musimy mieć identyczny stock rom, który mieliśmy wcześniej przed odblokowaniem BL czy wgraniem innego custom romu.

    Mnie zmyliło to, że pobrałem paczkę "XT1562_LUX_RETEU_6.0.1_MPD24.107-52.xml"   a soft miałem "XT1562_LUX_RETEU_6.0.1_MPDS24.107-52-5_cid7_subsidy-DEFAULT_CFC.xml"    

    Dodatkowo pomijamy komendę "fastboot flash bootloader bootloader.img", podczas flashowania.    

     

    Finalnie wygląda to tak: 

     

    fastboot oem lock begin
    fastboot flash partition gpt.bin
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    fastboot flash system system.img_sparsechunk.4
    fastboot flash system system.img_sparsechunk.5
    fastboot flash system system.img_sparsechunk.6
    fastboot flash system system.img_sparsechunk.7
    fastboot flash system system.img_sparsechunk.8
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1 
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    fastboot erase cache
    fastboot erase userdata
    fastboot oem lock
    fastboot reboot


    W załączniku dodaję gotowy plik "flash.bat", który wystarczy wrzucić do folderu ze wszystkimi plikami i adb, kliknąć 2 raz aby uruchomić i wszystko zrobi się samo, wystarczy chwilka cierpliwości ;) 

     

    PS. Zwrócicie również uwagę na liczbę waszych plików " system.img_sparsechunk.0,1,2,3 itd." Jeżeli np. macie 9 plików to po prostu edytujecie plik bat przez notatnik i dodajecie lub usuwacie komendę "fastboot flash system system.img_sparsechunk.X (x to numer pliku)"

     

    Zaznaczam też, że nie odpowiadam za uszkodzenia telefonów jeżeli coś pójdzie nie tak, wszystko robicie na własną odpowiedzialność.   
     

     

    flash.bat

    Edytowane przez log102

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wiceqq

    Odblokowałem bootloader, wgrałem TWRP, zrobiłem sobie backup systemu, wgrałem SuperSU z pierwszego posta i jestem zatrzymany na logo warning bootloader unlocked. Po drodze po każdej operacji wipe robione. Post niżej ktoś napisał, żeby wrzucić nowszego SU, więc wziąłem 2.79 z xda, i nadal to samo, jakieś sugestie dlaczego tak jest? Może przez to, że w TWRP dałem button format data -> yes?

     

    Edit: przywróciłem swój backup, wgrałem supersu ponownie i nadal to samo

    Edytowane przez wiceqq

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    dzidexx

    Zajrzyj do działu moto g4/g4+ - wątek root(marschmallow).

    Zrób jak tam opisane.

    @wiceqq

    • Lubię to! 2

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    wiceqq

    Owszem, ta metoda działa. Warto byłoby dla kolejnych osób w podobnej sytuacji zamieścić taką adnotację w pierwszym poście.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x