Skocz do zawartości
mitpio

Odblokowanie bootloadera , root , twrp, kernel,xposed...

    Rekomendowane odpowiedzi

    mitpio

    Witajcie.

    Jestem właśnie po odblokowaniu bl,roocie wgraniu kernela,twrp,oraz xposed i jego modułów całą noc zbierałem wszystko do kupy a poniewaz pierwszy raz rootowałem telefon tym sposobem troche się napociłem zwłaszcza że sposób wejścia do fastboot opisany jest zdawkowo , a więc dla kogoś kto tego nigdy nie robił czarna magia , a również ponieważ z tego powodu że zrobił się mały bałagan z tymi sposobami na forum to wrzuce wszystko do jednego miejsca , jeżeli pomogłem to super.

    1. Najpierw ( na obecną chwilę trzeba na stocku _6.0.1_39.0.A.3.30) trzeba zrobić kopie TA 

    2. Odblokowac bootloader

    3. Wgrac twrp

    4. Wgrac odpowiedni kernel ( czasem trzeba odwrotnie)

    5. Root

    6. Zmiana systemu flashtoolem ( po odblokowaniu BL nie ma innej metody ) wiąże się z ponownym wgraniem powyższych plików :((((

     

     


     

    1. Kopia kluczy TA ( DRM ).rar

     

     Łopatologicznie jak  zabrać się do odblokowania  bootloadera ,  wgrać  kernel lub wgrać TWRP za pomocą      fastboota .

     

    Wyłączmy telefon , który  jest odłączony od komputera, następnie trzymając przycisk zgłaśniania podłączamy telefon kablem usb z komputerem ,  kiedy zapali sie niebieska dioda wtedy wiadomo że jesteśmy w opcji fastboot , wtedy wchodzimy do folderu z zainstalowanym flashtoolem  (domyślnie dysk c folder o nazwie x10flasher_lib ) w folderze tym w wolnym miejscu ( na białym tle ) wciskając klawisz shift na klawiaturze , klikamy równocześnie ppm (prawym przyciskiem myszy) otwiera się pod menu gdzie ( nie puszczając klawisza shift ) klikamy na  pozycje otwórz okno polecenia tutaj , wtedy otwiera się okno wiersza polecenia gdzie dopisujemy do tego co nam się wyświetli komendę która jest nam potrzebna ,enter i już.

     

     

    2.  Odblokowanie bootloadera.rar

     

    3. TWRP

          https://mega.nz/#!hBFElCiD!6xIOWd8v9-o57KLcWx7eTuJl_NfiUg7Bs9pP5HExX80

     

    4. XZ_AndroPlusKernel_v05  dla _F8331_6.0.1_39.0.A.3.30_CentralEurope1

     

        XZ_AndroPlusKernel_v20  dla  _F8331_7.0_39.2.A.0.417

     

            https://mega.nz/#!MFMTkSTC!cLpSMpqsNwyfpmkYD2Tnhrw-EkkH1Mg1ShEZnvVGPTA

     

        

    5. Root.rar

     

    6. Xposed (sprawdzany na MM na N-ce jeszcze nie)

     

         https://mega.nz/#!MFV1TCpS!6UriUmVlCMvMIffV0UTGaiCOvX-pD7FObf0BXpVKonA

     

    W poście wykorzystałem ciężką prace @dante82  , @Wyso77 , i innych którym jestesmy wszyscy wdzięczni za włożoną pracę w tworzenie tego forum:)))))

    Edytowane przez mitpio
    • Piwko! 1
    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Wyso77

    Mam właściwie pytanie. Nie wiem czy do tego odnosi się punkt 6 - o czym myślę, ale mam wrażenie, że jak za pierwszym razem wgrywałem TWRP to potem po wgraniu ROMu mogłem wejść do niego z powrotem. Teraz za każdym razem mam coś takiego, że tylko raz mogę wejść do TWRP - zainstalować ROM i wrzucić wszystkie inne bajery. Potem po zainstalowaniu systemu podczas bootowania chcąc wejść do recovery zmienia się dioda na ten właściwy kolor wbijania do recovery, ale kiedy chcę wejść to tel. się restartuje. Ponowne wgranie przez flashtool lub cmd TWRP nie wchodzi w grę bo zabija cały boot i później non stop się uruchamia TWRP aniżeli system.

    Jest jakaś metoda na to? Nie wiedziałem, że kiedyś o to zapytam :P, ale zrobiłem coś źle? Czy mi się tylko wydawało, że dało radę ponownie wejść do recovery po postawieniu systemu?
    -mam na swoim koncie już dość sporo tych bootloaderów, recoverów, że zaczyna mi się mieszać.

    Edytowane przez Wyso77

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Powiem Tobie szczerze, że sam się nad tym zastanawiam. Gdy za pierwszym razem wgrywałem RomAur, miałem tylko drobne problemy, bo telefon, przy każdym uruchomieniu powracał do TWRP. Lekarstwem na to było ponowne wgranie kernela a co ciekawe TWRP nie zniknęło i bez problemu można je było uruchamiać. Problemy zaczęły się pojawiać, gdy robiłem downgrade z 7.0 do 6.0.1. Po wykonaniu wszystkich czynności co wcześniej ... po wgraniu custom roma telefon się normalnie uruchomił, co skutkowało brakiem recovery. Próby ponawiałem wielokrotnie, aż do uzyskania satysfakcjonującego wyniku. Najciekawsze w tym wszystkim jest to, że auror romu zaleca wpierw wgranie kernela, a później twrp. aczkolwiek nie ma wzmianki, iż po wgraniu roma,i przy każdorazowym uruchomieniu telefon powraca do recovery, dopiero wgranie kernela uwalnia go z tego nie kasując jednoczenie TWRP.

    @Wyso77 Powiem tak. Od wielu lat siedzę w modyfikacjach nie jeden telefon flashowałem i dochodzę do wniosku, że z każdą nową wersją androida jest coraz trudniej, tak jakbyśmy "się cofali" Pamiętam czasy Xperii Arc gdzie zrobić roota, to było nie lada wyzwanie... Reasumując: Android po woli staje się coraz "cięższy" na modyfikacje, co przykładem może być chociażby dostęp  do roota, gdzie od wersji 6.0 trzeba odblokować BL. czy tworzenie przez autora xposed framework.

    Moja rada próbuj, Ja bynajmniej nie znalazłem na to lekarstwa.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mitpio

    Tak jak napisałem czasem trzeba najpierw kernel potem twrp (tak było w moim przypadku wgrałem twrp i lipa dopiero jak kernel a potem twrp zadziałało ) ale tak to wszystko jest normalnie, ale tak jak pisze @dante82 coraz trudniej z modyfikacjami.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Wyso77
    1 godzinę temu, mitpio napisał:

    Tak jak napisałem czasem trzeba najpierw kernel potem twrp (tak było w moim przypadku wgrałem twrp i lipa dopiero jak kernel a potem twrp zadziałało)

    Szanowny... I sądzisz, że tego nie zrobiłem? To bym nawet nie pisał tego postu... Wiele kombinacji przeprowadziłem i lipa.
     

    9 godzin temu, dante82 napisał:

    Pamiętam czasy Xperii Arc gdzie zrobić roota, to było nie lada wyzwanie...


    To były czasy... Sam się wywodzę z czasów jak to wszystko zaczęło działać :). Pamiętam do dziś jakie jajca były z SE Xperia X8, albo kolejnym dość topowym SE Xperia Live with Walkman. Wspaniałe czasy, ale... To już historia...

    Nic... Jak uda mi się coś wymyślić i zrobić (bo już masę kombinacji przeprowadziłem i na razie kompletne dno), to z pewnością napiszę.
    Dzięki za wpis :).

    Edytowane przez Wyso77

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    ct65

    @Wyso77 czasem przy wychodzeniu z recovery twrp/philz/cwm pyta się, czy zablokować nadpisanie stockowym recovery lub czy zezwolić na nadpisanie stockowym recovery (nie pamiętam dokładnie). Nie miałeś czegoś takiego po pierwszym wyjściu?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mitpio

    Na jakich systemach to wam się dzieje? Na mm czy na n-ce?

    tapnął mitpio z xz

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Wyso77
    Godzinę temu, mitpio napisał:

    Na jakich systemach to wam się dzieje? Na mm czy na n-ce?

    tapnął mitpio z xzemoji3.png
     

    Na MM i N.

     

     

    1 godzinę temu, ct65 napisał:

    @Wyso77 czasem przy wychodzeniu z recovery twrp/philz/cwm pyta się, czy zablokować nadpisanie stockowym recovery lub czy zezwolić na nadpisanie stockowym recovery (nie pamiętam dokładnie). Nie miałeś czegoś takiego po pierwszym wyjściu?

    Nigdy nie widziałem takiego komunikatu. Używam tylko i wyłącznie TWRP bo CWM'a chyba jako tako nie ma na XZ. Korzystałem z różnych wersji od:

    https://kernel.andro.plus/tone2.html

     

    //Dodam, że czyszczenie do zera flashtoolem też nic nie daje. Czy to na MM czy N. Po wgraniu TWRP lub KERNEL + TWRP lub TWRP + KERNEL problem nastaje. Wchodzi tylko i wyłącznie do TWRP. Mogę sobie wgrać jakiś ROM, zrobić full wipe itp., a po instalacji ROMu system się bootuje normalnie, lampka się podczas bootowania pali, że mogę wejść do recovery, ale kiedy chcę wejść to jest restart i tak ciągle. Jak nie chcę wejść to normalnie bootuje system. Po ponownym wgraniu TWRP przez flashtool lub cmd to już nie bootuje do systemu jeno non-stop odpala TWRP. Trochę frustrujące jakbym chciał coś wrzucić w system.

    Edytowane przez Wyso77

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jak pisałem wcześniej... Sam się nad tym zastanawiam dlaczego tak się dzieje. Gdy za pierwszym razem wgrywanie Romans 2.1 to miałem tylko problem, że po poprawnym Flashu cały czas wchodził w twrp. Ponowne wgranie Kernela załatwił sprawe, a co ciekawe bezproblemowo odpalalo mi recovery. Problemy zaczęły się gdy robiłem downgrade z N do MM. By mieć obecnie RomAur + twrp falshowalem telefon z 10 razy i dalej nie wiem czemu tak się dzieje.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mitpio

    Ja wgrałem mm na centralną Europę i zero problemu może to wina systemu jaki wgrywamy?

    tapnął mitpio z xz

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.