Skocz do zawartości
mitpio

tutorial Odblokowanie bootloadera , root , twrp, kernel,xposed...

    Rekomendowane odpowiedzi

    ct65

    Albo po prostu nougat zaktualizował do nowszej wersji boota, dlatego się wykrzacza albo jedno albo drugie. 

    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    @ct65 Możliwe, że masz rację. Jak cofnę się myślami wstecz, podobne problemy bodajże były przy downgrade Xperii Z3, tam też były cyrki z flashem.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    patrikos23

    na z3 nie było żadnych problemów z flashem, miałem ten telefon dosyć długo i różne cuda z nim robiłem i żadnych cyrków nie było-to tak dla sprostowania

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    ct65

    @patrikos23 sony juz w nie jednym modelu mieszalo wraz z nowym systemem. Chociazby m2 mialo nowego boota, lollipop dla z1 tez grzebal w partycjach, wiec kto wie czy nie i w boot. 

    Korzystales na mm jak ja miales? Czy mowimy o z3c Twojej zony? Moze wlasnie tutaj jest roznica... 

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    patrikos23

    mówimy o z3 :P rozróżniam te telefony ;) miałem customy na mm, natomiast stock wg mnie to najlepszy był lizak i tylko na tym jechałem

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Wyso77

    @dante82

    Bardzo prawdopodobne, że znalazłem rozwiązanie. U mnie podziałało.
    Przypuśćmy, że zmieniam ROM:

    [typowa procedura]
    -robię Flash TWRP
    -czyszczę wszystko

    -następnie instaluję zipy (xROM, Kernel, poprawki i Root (SuperSU))
    -restart... (po którym świeci lampka ale już oczywiście nie działa TWRP. Ponowna próba wgrania TWRP zabije ROM i będzie się Bootować tylko TWRP nie umożliwiając wbicie na system)

    -po uruchomieniu systemu restartuję go jeszcze raz

    [rozwiązanie]

    -sprawdzam czy root działa, odblokowuje wszystkie zabezpieczenia (blokada oem i aplikacji)

    -loguję się do google makretu

    -pobieram i instaluję aplikację "Official TWRP App" (link)

    -uruchamiam aplikację, wybieram telefon (XZ), pobieram najnowszy TWRP

    -dokonuję Flash z poziomu systemu (przez ten program)

    -po zakończeniu restart

    -standardowe wejście do Recovery jest niemożliwe (podczas lampki naciskanie VOL-UP, VOL-DOWN) - będzie się restartować i uruchamiać do systemu

    -żeby wejść w Recovery należy uruchomić ponownie telefon i w trakcie ponownego uruchomienia trzymać POWER + VOL-DOWN. Tak samo jak byśmy się próbowali dostać do Flashmode. Następuje taka zmiana, że telefon się uruchamia dużym białym tłem z napisem XPERIA (bez informacji o odblokowaniu Bootloadera) i normalnie wbija do Recovery. Działa powrót do systemu. Wystarczy wyjście z Recovery (restart). I tak w koło jak chcemy wejść do TWRP. Sprawdziłem to kilka razy i u mnie działa. Nie daję gwarancji, że u innych też będzie to tak wyglądać, ale myślę, że nie powinno być jakiś większych problemów (piszemy o osobach posiadających mój problem). Właśnie instaluje inny system dzięki tej metodzie. Zobaczymy, może TWRP zgodzi się już zostać na stałe w moim telefonie :P. Jak nie to będę zmuszony wykonywać tą operację co nowy ROM. Plus taki, że zawsze "doinstaluję" sobie tego całego TWRP niż miałbym wszystko wrzucać przy pierwszym razie. I zabezpieczenia ^^. Prawie każdy zna metodę na guziczek podczas palenia się lampki gdy telefon się uruchamia, a kto połapie się o takiej możliwości wbicia na telefon przez TWPR? :P.

    Życzę powodzenia osobą posiadającym tą niewygodę z TWRP

     

     

     

    //Po postawieniu nowego systemu TWRP nie znika. Wszystko działa idealnie. Jedyny mankament to taki, że dostęp jest taki jaki opisałem powyżej.

    Edytowane przez Wyso77
    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    andy503

    Mam takie pytanie. W zasadzie zatrzymuję się na downgrade. Mam N-ke .417 z Orange. Zainstalowałem wszystkie sterowniki, które były wymagane i takie tam. Flashtool w wersji 0.9.23.1. Ściągnąłem  39.0.A.1.250 z UK i Orange żeby zrobić kopie TA. I problem pojawia się gdy próbuje wgrać wcześniej wymieniony ROM. Załączam log z flashtolla. 

    12/031/2017 15:31:48 - INFO  - Flashtool Version 0.9.23.1 built on 11-01-2017 15:12:00
    12/031/2017 15:31:48 - INFO  - Executing search strategies to find proxy selector
    12/031/2017 15:31:49 - INFO  - No proxy found for IE. Trying next one
    12/031/2017 15:31:49 - INFO  - No proxy found for firefox. Trying next one
    12/031/2017 15:31:49 - INFO  - No proxy found for java. Trying next one
    12/031/2017 15:31:49 - INFO  - Syncing devices from github
    12/031/2017 15:31:49 - INFO  - Opening devices repository.
    12/031/2017 15:31:49 - INFO  - Scanning devices folder for changes.
    12/031/2017 15:31:59 - INFO  - Pulling changes from github.
    12/032/2017 15:32:00 - INFO  - Quietly closing devices repository.
    12/032/2017 15:32:00 - INFO  - Devices sync finished.
    12/032/2017 15:32:00 - INFO  - Loading devices database
    12/032/2017 15:32:00 - INFO  - Loaded 94 devices
    12/032/2017 15:32:00 - INFO  - Starting phone detection
    12/032/2017 15:32:05 - INFO  - Device disconnected
    12/032/2017 15:32:25 - INFO  - Selected Bundle for Sony Xperia XZ(F8331). FW release : 39.0.A.1.250. Customization : United Kingdom
    12/032/2017 15:32:25 - INFO  - Preparing files for flashing
    12/033/2017 15:33:38 - INFO  - Device connected in flash mode
    12/034/2017 15:34:45 - INFO  - Please connect your device into flashmode.
    12/034/2017 15:34:46 - INFO  - Opening device for R/W
    12/034/2017 15:34:46 - INFO  - Reading device information
    12/034/2017 15:34:46 - INFO  - Phone ready for flashmode operations.
    12/034/2017 15:34:46 - INFO  - Opening TA partition 2
    12/034/2017 15:34:46 - INFO  - Current device : F8331 - CB512D8ELR - 1305-7308_R10C - 1302-9157_39.2.A.0.417 - GENERIC_39.2.A.0.417
    12/034/2017 15:34:46 - INFO  - Closing TA partition
    12/034/2017 15:34:46 - INFO  - Start Flashing
    12/034/2017 15:34:46 - INFO  - No loader in the bundle. Searching for one
    12/034/2017 15:34:46 - INFO  - No matching loader found
    12/034/2017 15:34:46 - WARN  - No loader found or set manually. Skipping loader
    12/034/2017 15:34:46 - INFO  - Loader : S1_Root_de8d - Version : 1299-4832_S1_Boot_MSM8996_LA2.0_N_110 / Boot version : 1299-4832_S1_Boot_MSM8996_LA2.0_N_110 / Bootloader status : ROOTABLE
    12/034/2017 15:34:46 - INFO  - Max packet size set to 4M
    12/034/2017 15:34:46 - INFO  - USB buffer size set to 512K
    12/034/2017 15:34:53 - INFO  - Parsing boot delivery
    12/034/2017 15:34:53 - INFO  - No flash script found.
    12/034/2017 15:34:53 - INFO  - Flash script is mandatory. Closing session
    12/034/2017 15:34:53 - INFO  - Ending flash session
    12/034/2017 15:34:53 - INFO  - Flashing finished.
    12/034/2017 15:34:53 - INFO  - Please unplug and start your phone
    12/034/2017 15:34:53 - INFO  - For flashtool, Unknown Sources and Debugging must be checked in phone settings
    12/034/2017 15:34:53 - INFO  - Device connected in flash mode
    12/035/2017 15:35:55 - INFO  - Device disconnected

     

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mitpio

    W moim przypadku musiałem wrócić do niższej wersji flashtoola zainstalować zrobić kopię i potem wersja ostatnia i najnowszy soft

    Wysłane z mojego F8331 przy użyciu Tapatalka

    • Lubię to! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    andy503

    Fajno dzięki. Spróbuje ogarnać. Na z3 nie było takich cyrków. Jak mogę zapytać, która wersja flashtool?

     

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mitpio

    Chyba 0.9.22.3 o ile mnie pamięć nie myli no takie cyrki tutaj jeszcze flashtoot nie taki jak trzeba

    Wysłane z mojego F8331 przy użyciu Tapatalka

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x