Skocz do zawartości
jemalx

Problem Eclipse SDK

    Rekomendowane odpowiedzi

    jemalx

    Witam, rozpoczynam wlasnie przygode z programowaniem na platforme Android i mam jeden, powazny problem.

    Jest nim podlaczenie telefonu do środowiska Eclipse w celu uruchomienia aplikacji. Po stworzeniu konfiguracji uruchomienia otwiera sie okno wyboru urządzenia lub maszyny AVD. I własnie tutaj tkwi problem, gdzyż nie wyszukuje mi telefonu. Sterowniki i oprogramowanie SE sa zainstalowane i nic z tego.

    System: Windows XP

    Telefon: Xperia X10

    Java Eclipse SDK

    Szukam rozwiazania...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mrmike
    Witam, rozpoczynam wlasnie przygode z programowaniem na platforme Android i mam jeden, powazny problem.

    Jest nim podlaczenie telefonu do środowiska Eclipse w celu uruchomienia aplikacji. Po stworzeniu konfiguracji uruchomienia otwiera sie okno wyboru urządzenia lub maszyny AVD. I własnie tutaj tkwi problem, gdzyż nie wyszukuje mi telefonu. Sterowniki i oprogramowanie SE sa zainstalowane i nic z tego.

    System: Windows XP

    Telefon: Xperia X10

    Java Eclipse SDK

    Szukam rozwiazania...

    Sprawdź czy masz włączone debugowanie w telefonie. Odpal w konsoli

    adb devices

    pokaże Ci listę działających urządzeń.

    Jak system dalej nie będzie widział telefonu, kombinuj z reinstalacją sterowników

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    jemalx

    Tryb debugowania był włączony.

    *Opcji abd drives nie użylem, bo nie chcialo pójść.

    dodalem lokalizacje SDK do zmiennych środowiskowych, ale nie zadzialało.

    (Robiłem tak przy rootowaniu x10 mini pro.)

    *Opcja z reinstalacją sterowników poskutkowała, ale tylko w jedną strone, czyli udało mi się je usunąć. W SDK Menager opcja ponownego zainstalowania sterowników USB się nie pokazała.

    Mimo tego wszystkiego działa. Eclipse wyszukuje Xperie. Sądze ze sterowniki usb z SDK mogły się "gryźć" z tymi od Xperii i dlatego nie było pożądanego efektu. Teraz jest.

    Dzięki, mrmike. :D

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    mrmike

    Żeby adb działało w konsoli musisz dodać zmienna środowiskową(Prawym na komputer -> zaawansowane ustawienia > zmienne środowiskowe > i w PATH dodaj po średniku lokalizacje do katalogu tools w android sdk (przykładowa)

    C:\Program Files (x86)\Android\android-sdk-windows\tools

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x