Skocz do zawartości
Shavo6

[Rozwiązany] Problemy z instalacją Viper4Android\Viper4Arise

Rekomendowane odpowiedzi

Shavo6

Siedzę aktualnie na stocku i OOS doprowadza mnie do szewskiej pasji podczas prób zainstalowania V4A. Zainstalowałem Viper4Arise z tego tematu, zaznaczajac przy instalacji core,v4a, tryb kompatybilności z magiskiem. Po reboocie pojawiłą się apka V4A ale po otwarciu wywala odrazu komunikat "The driver needs to be reinstalled. Do you want to do this now?" Klikam oczywiście "Yes", sterowniki się instalują i program prosi o reboot telefonu. Po ponownym uruchomieniu cała historia od nowa... Przypomniałem sobie, że V4A kiedyś potrzebował Busybox do poprawnego działania. Pobrałem i zainstalowałem go więc ze sklepu play, jednak znowu coś nie bangla, bo dostaje komunikat, że instalacja nie została zakończona powodzeniem i żeby spróbować zmienić lokalizacje instalacji (bez skutku). Komuś się powiodło ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Shavo6

Niestety, to samo. Nawet wydaje mi się, że próbowałem Twój sposób jakiś czas temu.

 

Znalazłem coś takiego https://forums.oneplus.net/threads/guide-how-to-install-viper4android-on-oneplus-3-3t-nougat.488131/. Jednak mam problem właśnie przy kroku instalacji Busybox. Czy w Magisk 14.0 zmieniło się coś odnośnie instalacji Busyboxa ? Coś mi się obiło o uszy, że chyba zaimplementowali BB ?

Edytowane przez Shavo6

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
dzidexx

Masz magisk?

Przywróć fon do stanu przed próbami z viperem, tzn. stock system + magisk.

Wgraj jako moduł stąd:

https://forum.xda-developers.com/apps/magisk/module-viper4android-fx-2-5-0-5-t3577058

@Shavo6

dodana zawartość

Jako moduł:

Pobrany v4.zip skopiuj do folderu Magisk Manager, wgraj w twrp lub w MagManager - moduły - ➕

  • Piwko! 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Shavo6

Tak zrobiłem, instalacja na czysty system z Magisk 14.0. Zainstalowałem moduł przez przycisk "plus". V4A zainstalował się razem z aplikacją. W driver status sterowniki są niby zainstalowane, ale wszystkie pozycje są na "no". Próbowałem odinstalować sterowniki i zainstalować ponownie, ale wróciłem wtedy do powracającego błędu z instalacją sterowników i rebootem. Próbowałem też doinstalować apke od Roy, ale widocznie nie da się tego zrobić gdy już zainstalowana jest inna.

 

Używam Powerampa, suwak music fx jest włączony. Po przytrzymaniu przenosi mnie do ustawień V4A, pauzując na chwile dźwięk ale nic pozatym się nie zmienia.

Edytowane przez Shavo6

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
dzidexx

Sprawdzałeś na innym odtwarzaczu?

 

10 sposobów na raz nie pomoże, trzymaj się jednego.

 

Jeśli chcesz pomocy ode mnie sprawdź ponownie to co podałem z innymi odtwarzaczami.

Jak nie będzie działać spróbujemy innego.

@Shavo6

dodana zawartość

Ps.

W power amp trzeba coš powyłączać. Głośność bezwgzl?

  • Piwko! 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Shavo6

Możesz zaproponować jakiś odtwarzacz(e) na których jesteś pewien że V4A działa na OP3 ? Na LG G2 poweramp ogarniał, ale tu być może jest inaczej. Spokojnie, nie 10 sposobów na raz. Spróbowałem wpierw po Twojemu, ale skoro nie zadziałało to robie co mi tylko przyjdzie na myśl :P 

 

Jak najprościej i najpewniej zmienić Selinux na permissive ? Spróbuje powyższe sposoby jeszce raz z selinux permissive i zainstalowanym busyboxem (który jakimś cudem się naprawił sam).

 

EDIT: Tak, myślałem właśnie o tym przed chwilą. Bezpośrednia kontrola głośności jest wyłączona.

Edytowane przez Shavo6

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
dzidexx

Permissive:

Terminal:

su 

getenforce

setenforce 0

getenforce

 

Dowolny player(black, jet, muzyka google) žeby sprawdzić.

@Shavo6

  • Piwko! 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

@Shavo6 spróbuj zainstalować busybox stad: https://play.google.com/store/apps/details?id=ru.meefik.busybox

U mnie instalowały się bezproblemowo a te od Stericsona sypały komunikatem o wyborze lokalizacji.

Wysłane z mojego ONEPLUS A3003 przy użyciu Tapatalka

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Shavo6

@dzidexx

Jak by ktoś sie babrał z tym tak jak ja:

1) format /system i instalacja systemu przez twrp

2)instalacja magisk 14.0 bez bootowania

3)instalacja busybox

4)instalacja modułu do magiska od @dzidexx

5)reboot, terminal i setenforce 0. Niestety po każdym reboocie przestawia się spowrotem na enforcing.

 

Dziękuje za pomoc. Wszystko działa :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.