Skocz do zawartości
Shavo6

SafetyNet - dlaczego nie działa ?

    Rekomendowane odpowiedzi

    Shavo6

    Chciałem dzisiaj zainstalować sobie Android Pay, ale okazało się że SafetyNet nie puszcza niestety :/ Myślałem, że to wina roota więc wyczyściłem partycje system i cache. Zrobiłem dirty flasha i wrzuciłem jeszcze raz OOS 5.0.1. I teraz zmieniło się tylko to że basicIntegrity mam poprawne ale CtsProfile nadal nie...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    a bootloader zablokowałeś?

    • Piwko! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Shavo6

    Nie. Czy masz pewność że odblokowany bootloader uwala safetynet ? Kiedyś udawało mi się z samym magiskiem i odblokowanymi bl ogarnąć to wszystko. Nawet recovery (nie wiem dlaczego) powróciło mi do stockowego. Więc są 2 opcje, albo jakieś pozostałości po roocie, apka\ pliki na sd (wogóle safetynet sprawdza pamięć sd czy tylko systemową?) albo właśnie coś się zmieniło od Nougata i odblokowany bl wyzwala safetynet.

    Edytowane przez Shavo6

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    dzidexx
    5 minut temu, Shavo6 napisał:

    Czy masz pewność że odblokowany bootloader uwala safetynet

    Tak.

    Magisk potrafi oszukać/ukryć ten fakt poprzez modyfikację boot(kernel).

    Musisz wgrać czysty stock, ewent. wyczyścić śmieci po rootowaniu i użyć najnowszy magisk15.x.zip.

    • Piwko! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    oczywiście że bootloader uwala saftynet ;)

     

    jakby co to superSU też potrafi ukryć wszystko przed SafetyNet'em więc masz 3 opcje:

    - wywalić wszystko i zablokować bootloader (niestety wiąże się to z całkowitym wyczyszczeniem urządzenia)

    - zrobić root za pomocą magiska 15.3 i ukryć roota w ustawieniach magisk manager'a

    - zrobić root za pomocą superSU, skonfigurować SuperSU na SBIN mode (osobnym zipem), + superSU hide (czyli 3 zipy w TWRP po kolei załatwiają sprawę)

     

    każda z metod pozwoli Ci używać Android Pay, ja używam 3 sposobu i AP działa tak jak powinno, SafetyNet przechodzi

    Edytowane przez bartolinio
    • Piwko! 1

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Shavo6

    Macie racje. Dzięki wielkie za szybką pomoc. W takim razie na ostatnim Magisku 15.3 miałem błąd bo próbowałem zainstalować V4A. Teraz jest wszystko ok.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.