Skocz do zawartości
HarryRobinson

Root dla Samsung i5800 + gps fix

    Rekomendowane odpowiedzi

    Podłączam telefon do USB, telefon robi PIK ale powinien pokazać opcję wyboru przez co chcę się połączyć (KIES, Pamięć masowa, modem, itd).

    Nie powinien, chyba, że sobie ustawisz tak w ustawieniach telefonu. Jeśli nie będzie wykonywało domyślną akcję. Jeśli szuka w nieskończoność napewno masz zrootowany telefon, a wtedy z kies-em się nie połączy.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    kstn
    Zauważyłem jedną rzecz. Podłączam telefon do USB, telefon robi PIK ale powinien pokazać opcję wyboru przez co chcę się połączyć (KIES, Pamięć masowa, modem, itd). Do tego KIES szuka urządzenia w nieskończoność. Mam Win7. Wiecie może co jest nie tak?

    U mnie jest dokładnie taka sama sytuacja. Z tym że ja mam XP.

    Telefon robi PIK na znak ładowania baterii, nic poza tym się nie dzieje.

    Jeszcze zanim wrzuciłem Kiesa telefon normalnie pytał przy podłączeniu jaki tryb USB ma wybrać, teraz po zainstalowaniu Kiesa telefon tylko pika i nawet nie chce się połączyć.

    Wie ktoś o co może tu chodzić? Może to przez ten poryty soft z ERY?

    Jeśli szuka w nieskończoność napewno masz zrootowany telefon, a wtedy z kies-em się nie połączy.

    No to nie możliwe, bo telefon napewno nie jest zrootowany.

    Edytowane przez kstn

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Kanet

    Ja wczoraj aktualizowałem kiesa

    i od tego czasu nie widzi on mojego i5800(ale jako pamieć masowa na kompie jest).

    Może ta nowa aktualizacji coś popieprzyła?:)

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    A jak w terminalu wpiszesz su, to zmienia się z $ na #?

    Jeśli nie to nie masz roota, a jedynie wrzuconą aplikację superuser. Zrootuj telefon metodą którą podałem chyba na 2 stronie tego tematu, ona działa na każdy ROM

    zmienia sie.. jednak nie rozumiem tego o0

    co do postow powyzej cos gdzies mi sie rzucilo w oczka na innych forach (niestety teraz nie znajde zrodla) ze komus telefon automatycznie ustawial sie jako modem dialup. podobno jakis kod #*

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Telefon robi PIK na znak ładowania baterii, nic poza tym się nie dzieje.

    Jeszcze zanim wrzuciłem Kiesa telefon normalnie pytał przy podłączeniu jaki tryb USB ma wybrać, teraz po zainstalowaniu Kiesa telefon tylko pika i nawet nie chce się połączyć.

    Mam dokładnie to samo. W7,Era.,

    ED. Jest ok. DZIŚ mam mozliwośc wyboru.

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    kstn

    Udało się! Wkońcu zrootowałem mój sprzęcik.

    Mam dokładnie to samo. W7,Era.,

    ED. Jest ok. DZIŚ mam mozliwośc wyboru.

    w tym przypadku pomogł mi kod *#7284# wyczytany gdzieś na forum.. Wystarczy zmiana z modem na PDA i wszystko zaczęło hulać bez problemu.

    A co do roota - zrobiłem go w pełni trochę pod górkę ale jednak udało się gdyż wywaliłem wszystkie niechciane aplikacje wrzucone przez ere itp itd.

    opiszę to w krokach:

    1. Podłączenie do kompa - i tu był pierwszy problem z modemem, którego rozwiązanie napisałem wyżej.

    2. Tryb Debugowania w telefonie

    3. Odpaliłem superoneclick na kompie (XP) i wszystko zaczęło lecieć. Komunikat na końcu mówił mi że zrootowałem swój telefon, aczkolwiek w logu dostałem info:

    Pushing superuser.apk...

    failed to copy 'superuser.apk' to '/system/app/superuser.apk': No space left on device

    chodź komunikat głosił że telefon został zrootowany poprawnie, nie wrzucił aplikacji superuser z uwagi na niby brak miejsca w pamięci wewnętrznej, chodź wolne było 110mb. Stwierdziłem iż w takiej postaci tego nie zostawie.

    4. Wrzuciłem aplikację superuser na kartę SD

    5. Programem ASTRO zainstalowałem superuser'a

    6. Ściągnąłem emulator terminalu, dodałem go do listy programów w superuserze i po wpisaniu su (zalogowaniu się na konto roota) bazując na znajomości podstawowych komend z których korzystam na codzień na swoim Mincie próbowałem przenieść instalkę superusera do katalogu /system/app - nieskutecznie, dostawałem błąd "cross device link" i nic z tego. Nie poddałem się.

    7. Przeczytałem gdzieś o programie Root Explorer i zassałem go z applanetu

    8. Po chwilowym zaznajamianiu z Root Explorerem dodałem go do listy w superuserze i wszedłem do folderu /system/app

    9. Spóbowałem skopiować po raz kolejny superusera do /system/app lecz znów dostałem info że jest za mało miejsca - stwierdziłem że chyba coś jest nie tak

    10. Zaznaczyłem mu żeby mi włączył możliwość zapisu w plikach read only i usunąłem kilka badziewnych aplikacji od Ery typu Sims 3 demo, monopoly demo, BlueConnect itp

    10. Wychodzi na to że wywalając powyższe niepotrzebne nikomu aplikacje zrobiłem sobie miejsce w /system/app i bez problemu skopiowałem superuser.apk

    Było trochę zabawy ale myślę że się opłacało!

    Pozdrawiam

    //Edit: zapomniałem dodać: bezcenny jest dreszczyk emocji amatora przy każdym resie telefonu po jakiejś tego typu operacji, polecam! : - )

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Geno85

    Ja sobie dalej nie moge poradzic z tym Waiting for device... pozniej zobacze na innym kompie... moze sie uda...

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Nie mogłem zrootować firmware'u Ery: PDA: I5800XWJH3, PHONE: I5800XXJG3, CSC: I5800ERAJG1

    Wrzuciłem przed Odin'a najnowszą wersję: I5800XXJK1, PHONE: I5800XXJH1, CSC: I5800OXXJK1

    Na tym nie brandowanym działa z4root z Android Marketu i jest root.

    Poza tym nie ma tony bradowanych aplikacji i lepiej działa wifi (lepszy zasięg). :D

    Brakuje mi jeszcze usuwania polskich znaków z sms'ow. :cii:

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    vilajn

    Mi dzis udało sie zrootowac brandowany soft z Plusa xwji8 z4root'em

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach
    Geno85

    u mnie nawet na 2 kompie "Waiting for device..." jakies propozycje?

    Udostępnij tę odpowiedź


    Odnośnik do odpowiedzi
    Udostępnij na innych stronach

    Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

    Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

    Zarejestruj nowe konto

    Załóż nowe konto. To bardzo proste!

    Zarejestruj się

    Zaloguj się

    Posiadasz już konto? Zaloguj się poniżej.

    Zaloguj się

    • Ostatnio przeglądający   0 użytkowników

      Brak zarejestrowanych użytkowników przeglądających tę stronę.

    x